Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I used Settings > General > Reset > Reset All Settings on my iPhone, and now incoming phone calls are displayed as the telephone number, rather than the name from my Contacts.

I do notice that the telephone numbers in my Contacts app are (now?) simply a string of 10 digits, rather than being formatted. I'm pretty sure it was formatted at one point.

Thought it might have something to do with International Assist, but turning that on or off doesn't change this.

I don't recall having to set anything initially to enable caller i.d., so I don't know what setting might have been reset.

Suggestions? Thanks!

share|improve this question
add comment

1 Answer

The solution to my problem turned out to be reactivating my (Verizon) phone. Details here: https://discussions.apple.com/thread/3766509

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.