Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to install the Gitx Git client on my friend's mac and it seems to install fine but when I run it I get the following error:

You cannot open the application "GitXStable" because it is not supported on this architecture.

Ideas?

share|improve this question

closed as not a real question by Mark, bassplayer7, patrix, bmike Jan 26 '13 at 16:13

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

4  
It would be great if you tell us the Operating System and Mac’s model of your friend, our crystal balls are out of battery ;) –  Martín Marconcini Nov 20 '10 at 21:55
add comment

2 Answers 2

up vote 2 down vote accepted

Intel application on a PowerPC Mac. Or vice versa. See if you can find an "Universal Binary" version of the application, which will run on either platform.

This link has a Universal Binary version: http://frim.frim.nl/GitXStable.app.zip

share|improve this answer
add comment

I recommend you to use this version of GitX. Here is the direct link to download. Supported architectures are ppc7400, i386, x86_64.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.