Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Whenever I plug-in my earphones with a round connection into my MacBook Pro, the sound automatically switches to them. Whenever I plug my headphones with a USB connection (Logitech USB ClearChat Comfort Headset) and I am playing sound in iTunes, the sound automatically switches. Whenever I plug in my headphones and VLC is playing, the sound continues to play through the speakers. Is there any way to make VLC work with my USB headphones?

Update: It seems that the headphones don't work properly with Skype either.

share|improve this question
    
Both VLC and Skype should have a setting somewhere in their preferences to choose the output device. –  Joel Spolsky Nov 22 '10 at 0:31
    
Skype yes, VLC, I don't think so. Too many "preferences" ~_~. –  Jason Salaz Nov 24 '10 at 7:20
add comment

5 Answers 5

up vote 3 down vote accepted

Ask and you shall receive...

I logged this as a bug on VLC and they delivered within 2hrs!

https://trac.videolan.org/vlc/ticket/9231

share|improve this answer
add comment

VLC can't switch audio interfaces on-the-fly. You either have to stop playing media entirely, and go into the preferences and change it, then start playing your media again; or, the slightly easier way:

  1. Kill VLC
  2. Plug in headphones (and ensure they become the primary output sound device, hold option and click the sound icon in your menu bar, select usb headphones if necessary)
  3. Start VLC

Assuming VLCs preferences are still set to use the Default Audio Device for output, then it'll use them when you start playing content again.

share|improve this answer
    
As an aside, when I plug in my USB Headphone adapter, VLC locks up entirely, can't do anything but force quit, any currently playing media stops entirely. It's very frustrating. –  Jason Salaz Nov 22 '10 at 3:41
1  
If you have no “particular” reason to use VLC, I suggest that you try a few of the existing alternatives (Like QuickTime+Perian, to name just a popular alternative). Of course if you rely too much on VLC, all you can do is file a bug report to them, because the behavior VLC is having is not in sync with other Audio Applications in the Mac ecosystem.- –  Martín Marconcini Nov 22 '10 at 12:42
    
I use Movist, currently. I don't use VLC often, but I do for some purpose that I cannot currently remember, I think it has a work specific purpose, but I've been on vacation :). –  Jason Salaz Nov 23 '10 at 1:07
add comment

Since you're getting iTunes and system sounds through the headset, it should be set as the default audio device, but check the the Sound Preferences pane to make sure. After this, try restarting VLC to get it to use the new default audio device. This should also work for Skype, however Skype should have options in the preferences menu that will let you choose the audio output/input device. Unfortunately there doesn't seem to be any similar option in VLC.

share|improve this answer
2  
Skype lets you use “different” settings than the Default (i.e.: you could have a set of “skype dedicated” headphones/mic. It may be that VLC is not seeing the change and it needs a restart, given that VLC doesn’t have a way for you to choose the audio input/output. –  Martín Marconcini Nov 20 '10 at 21:54
add comment

Exiting VLC player, and then changing the default Sound Output to Logitech USB Speakers worked for me. So long as the Logitech speakers are plugged in before you open VLC player and System preferences are set correctly then VLC should play through the Speakers.

I know a lot of people use VLC player instead of Quicktime, because some Windows files don't play sound on Quicktime, but work perfectly on VLC player. Although this may have changed since Snow Leopard and the latest version of Quicktime.

Hope this helps. Toria

share|improve this answer
add comment

Hmm, I can switch audio devices in VLC on the fly without problems:

enter image description here

It defaults to the device defined in the system settings on startup.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.