Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'd like to force-include some files in Time Machine. Specifically I want to force-include "iPod Photo Cache" and "Thumbnails" in my Aperture Library.

I have checked this file: /System/Library/CoreServices/backupd.bundle/Contents/Resources/StdExclusions.plist

but those folders are not in it, however Time Machine still does exclude them. Is there anywhere else that Time Machine checks for exclusions?

Aside: Why?

In case anyone wonders why I would want this. I have a Mac Mini which acts as a media server that all my iThings sync to. This Mac Mini is also the Backup server and it's set up nightly to pull media off various time machine sparsebundles into its own library. This way:

  1. Any iDevices can sync wirelessly any time they're plugged in, not just when laptops are on and not sleeping
  2. No extra data needs to get pushed over wifi at regular intervals. Everything is just grabbed from Time Machine which gets automatically updated, for free.

All this works pretty well :) …that is until some Aperture or OS update started excluding the folders above for Aperture.

share|improve this question
    
I wonder if the excluded folders have any extended attributes associated with them that cause TM to skip them? Or perhaps they have the nodump flag set? Use xattr to look for extended attributes. Use ls -ldO (thats capital O, not number zero) to check for flags, use chflags to change them if needed. –  Harald Hanche-Olsen Feb 25 '12 at 9:05

2 Answers 2

up vote 2 down vote accepted

Open Terminal.app, type "cd " (Take care of the space after the cd) and drag your Aperture library in that window, then hit return. Now type

xattr -d com.apple.metadata:com_apple_backup_excludeItem "iPod Photo Cache"
xattr -d com.apple.metadata:com_apple_backup_excludeItem "Thumbnails"

Hit return again and do a backup.

share|improve this answer
    
Doesn't seem to work :( However it looks like it should work since doing xattr on those folders confirms that metadata flag has been set, but removing them and doing a backup doesn't seem to push this new data. I wonder if there's some kind of cache that I need to clear or some way to flag the folder as "hey, look at me, I've been newly unexcluded". –  kLy Feb 26 '12 at 20:11
    
I don't think so. I just tried and it worked :-? –  Max Ried Feb 27 '12 at 7:11
$sudo tmutil removeexclusion <file name>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.