Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

The title says everything, how can I disable the visual bell animation in Lion?

It is annoying and useless, visual bell should be fast, not fancy!

I don't want to disable the visual bell, just the fadin/fadeout animation.

share|improve this question
2  
What visual bell animation? All I see is a sudden change in the brightness of the window, followed by a fade back to normal. The fade takes less than a second, and is not at all annoying to me. What do you see? Dancing bunnies? –  Harald Hanche-Olsen Feb 24 '12 at 14:39
    
That fade back is the annoying thing, which is not necessary at all. And it is slow on a big display. –  KARASZI István Feb 24 '12 at 15:19
    
Terminal's visual bell is modeled on the system-wide visual bell available via System Preferences > Universal Access > Hearing > Flash the screen when an alert sound occurs. How do they compare to you? Terminal's should not take longer than that. If you're having a performance issue, it's worth investigating. How big is your terminal display usually? What sort of Mac hardware are you using? Is your terminal window translucent or opaque? Is the animation noticeably slow when the terminal window is very small? –  Chris Page Feb 26 '12 at 12:27
    
If the performance of the visual bell is an issue, or if you would like a preference for a different visualization (e.g., prior to Lion, it merely inverted the screen colors 100% and then back, but many people disliked it because it was so harsh), please let Apple know using the feedback website apple.com/feedback/macosx.html or by filing a bug report (requires a free developer account) developer.apple.com/bugreporter –  Chris Page Feb 26 '12 at 12:32
    
I would like to change the behavior of the Terminal, not the whole system. Changing the Universal Access would do a different thing. –  KARASZI István Feb 26 '12 at 19:48

1 Answer 1

  1. Go to the "Terminal" menu
  2. Select "Preferences"
  3. Select "Settings" at the top
  4. Select "Advanced" at the right
  5. Uncheck "Visual Bell"

Terminal preferences - Settings - Advanced

share|improve this answer
    
No, I don't want to disable it. I want to disable the animation –  KARASZI István Feb 24 '12 at 15:18
1  
Guys, seriously? Upvoting an answer which is not solving the question? –  KARASZI István Feb 24 '12 at 21:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.