Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have multiple external disks on my machines.

They are "green disks" and spin down/power save when they have not been accessed for a while.

When I right click on a file in Finder, then select "Open With" I get a spinning beach ball for a few seconds and I can hear my external drives spinning up. I have no applications on my external drives.

How can I stop the spinning beach ball from happening when selecting "Open With"?

It seems to be related to the external drive being in power save mode. Although I can't confirm this.

share|improve this question

2 Answers 2

Usually, you can stop the startup disk from spinning down by going to System Preferences > Energy Saver, then unchecking "Put the hard disks to sleep when possible". However, whilst this is certainly true for the startup disk, whether this is adhered to by external drives seems to be wholly dependant on the drive itself.

This page has more information, including a description of your problem, but also says

Second, some non-startup drives simply ignore the setting of Put the hard disk(s) to sleep when possible and spin down on their own schedule. This appears to be a function of either the drive itself or, in the case of external drives, the firmware or chipset employed in the drive's enclosure. In such a case the drive's Standby behavior cannot be changed. One can contact the manufacturer of the drive or enclosure to see if a firmware update is available to improve its cooperation with Mac OS X power management.

The only other way I can think of around this, if the above doesn't work, is forcibly keeping the drive awake. To do this you could simply set up a script to touch a file on the external drive at fixed intervals.

share|improve this answer
    
Yes, the only way to keep externals alive is with a periodic job that touches a file on them. Sad, but true. –  Ian C. Feb 24 '12 at 0:17

I can't reproduce this behavior, but troubles with the "Open with..." menu are often caused by an outdated or damaged launchservice database. Try to rebuild it with

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

in Terminal.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.