Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Having an iPhone and iPad lying on the desk while chatting with the new Messages beta app gets very annoying, as each device beeps separately.

Is there any way to have the notifications only on the current device as long as it is active?

share|improve this question
When using messages in ML, I have found that it doesn't actually alert my iPhone of notifications, not sure how it knows, but if I am actively using the OS X app, the iOS one get's updated with the contents but doesn't actually alert Perhaps it's based on read receipts, as I use them. If it knows I have read it on device A), then don't alter on device B)? Try setting them on and see what happens. Providing as a comment not an answer as it's conjecture. – stuffe Feb 23 '12 at 15:49
Ok, I enabled read receipt and restarted Messages, but the iPhone is still ringing. Not sure why it's working for you. I am on Lion though. – Timm Feb 23 '12 at 18:59
@Timm He is running Mountain Lion, that might have something to do with it… – timothymh Feb 24 '12 at 1:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.