Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Is there a way to lock my screen but not sleep my network connection? I step away from desk quite a bit and I lock the screen pretty much every time. When I come back I always from stepping away for like 5 minutes it seems like my machine has to reacquire an IP. This via ethernet. This is on a 2010 13' unibody macbook pro running Lion.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

User Geraard's answer in this forum posting might help. The suggested settings changes seems to have fixed his problem:

  1. Click the Apple Icon at top left of your screen.
  2. Select System Preferences.
  3. Select and open Network
  4. At the lower right select Advanced
  5. This will bring up the PPPoE screen with a menu bar showing TCP/IP, DNS, WINS, Proxies, PPP
  6. Select PPP to access the drop down menu and then you can make changes. On the SECOND LINE PROMPTS: I change the value from 0 minutes to 999 minutes. This cured the Pop-up Message to Reconnect that was happening.

Apple support seems to concur:

If you keep disconnecting from the Internet

If you have to redial your dial-up modem Internet connection after not using your computer for a few moments, or reconnect your PPPoE connection, your computer may be set to disconnect automatically when the connection is idle.

  1. Choose Apple menu > System Preferences, and then click Network.
  2. Select your modem port (internal or external) or your PPPoE configuration from the Services list, and then click Advanced.
  3. Click PPP, and then make sure the “Disconnect if idle for __ minutes” checkbox is not selected, or if it is selected, increase the number of minutes before that the computer will remain idle before disconnecting.

With luck, this setting change will solve your problem.

share|improve this answer
    
Is this still accurate? I do not see a "PPP" option under Advanced network settings for an Ethernet connection. –  FGreg Jun 27 at 19:01
    
@FGreg it does not exist on 10.9.3 –  Buscar웃 Jun 27 at 19:42

If your MacBook is plugged in I would try the following.

  1. Change the Engery Prefs to not spin down the disk or sleep the computer when it's plugged in.

  2. Activate the Screen Saver to turn on at a hot corner.

  3. Set the Screen Saver prefs to require password to log back in.

Now see if activating the Screen Saver causes you to loose your assigned IP.

The alternate method is to manually assign an IP to your MacBook while you're at work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.