Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a third generation iPod touch. I believe that it should be possible to run iOS 5 on this, and I have bought an app that requires iOS 5. However, in iTunes, when I click on the iPod device, it says that my iPod software is up to date. It says that the software version is 4.2.1. I'm registered with Apple with a Belgian account, though I hope this wouldn't make a difference to updates.

Any suggestions appreciated.

share|improve this question
3  
My guess is it is an 2nd gen iPod touch. Have you confirmed that it is 3rd gen? –  bassplayer7 Feb 22 '12 at 19:29
1  
Did you try steps in macworld.com/article/162925/2011/10/… ? –  Global nomad Feb 22 '12 at 19:30
add comment

2 Answers

up vote 4 down vote accepted

According to Apple, the 3rd gen iPod Touch can be upgraded to iOS 5. However, you may want to confirm that your iPod is not a 2nd gen version - those can only be upgraded to 4.2.1.

Apple Support has the following information to confirm your version (full page):

iPod touch (3rd generation) features a 3.5-inch (diagonal) widescreen multi-touch display and 32 GB or 64 GB flash drive. You can browse the web with Safari and watch YouTube videos with Wi-Fi. You can also search, preview, and buy songs from the iTunes Wi-Fi Music Store on iPod touch.

The iPod touch (3rd generation) can be distinguished from iPod touch (2nd generation) by looking at the back of the device. In the text below the engraving, look for the model number. iPod touch (2nd generation) is model A1288, and iPod touch (3rd generation) is model A1318.

Also, per Apple Support - make sure that you've upgraded to iTunes 10.5 before you begin the upgrade.

share|improve this answer
2  
Indeed, it is a second generation iPod. I thought that I'd checked that already, but not with a reliable soure. Thanks. –  JohnC Feb 22 '12 at 23:29
add comment

You will need to update iTunes to version 10.5 before you update your iPod. The 3rd generation should update to iOS 5. To check the iPod version number follow this KB article.

http://support.apple.com/kb/HT1353?viewlocale=en_US&locale=en_US

share|improve this answer
    
Had already updated to the latest iTunes. Thanks anyway. –  JohnC Feb 22 '12 at 23:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.