Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My early 2008 Macbook Pro was recently fixed for the known "MLB for NVIDIA" issue. Since I've gotten my computer back, my external monitor no longer has the correct resolution available. This was working fine before. I've tried resetting PRAM and the problem still persists. Why?

Computer: Early 2008 Macbook Pro, OS X 10.5.8 Monitor: Acer 19"

share|improve this question
I assume that the external display works, just that 1440x900 is not longer available? Are you using a DVI connector on the monitor or VGA? – mjturner Feb 23 '12 at 9:54
@mjturner, I'm using a VGA connector. – chrisofspades Feb 23 '12 at 18:36
I assume that's the same connector you were using before? I know this is clutching at straws a bit, but if your monitor has a DVI connector, can you perhaps try that instead? – mjturner Feb 23 '12 at 23:48
Yes, it's the same connector. The monitor does not have a DVI connector, so that isn't an option. – chrisofspades Feb 23 '12 at 23:56
FYI, I have no problem getting 1440x900 on a Dell using the same monitor. – chrisofspades Feb 24 '12 at 5:56

I'm not sure if this'll help (as the resolution should be available without resorting to third party software), but perhaps try SwitchResX and see if it makes the resolution available?

share|improve this answer
Yup, I tried that and 1440x900 still doesn't show up. Some resolutions that I get are 640x480, 800x600, 1024x768, 1280x768, 1280x960, 1344x1008, 1400x1050, etc. – chrisofspades Feb 27 '12 at 16:43
:( You can also create custom resolutions with SwitchResX - perhaps you can try that? Shouldn't be needed, but we're running out of ideas here... – mjturner Feb 28 '12 at 22:20
I couldn't get the custom resolution to work either. – chrisofspades Feb 29 '12 at 23:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.