Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've seen a lot of posts out there that say that iOS 5 causes 3rd Generation iPod Touch's to no longer function. Is this true? Is is safe to install iOS 5 on my 3rd Generation? Is there a special way that i need to do it?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

You can only install iOS 5 on the 32/64GB versions of the 3rd Generation iPod Touch. The other versions are technically 2nd Generation and so iOS 5 causes seriously problems when someone tries to install it on one of those.

share|improve this answer
add comment

It is, at least in theory, possible. See the Wikipedia article for more information. Installing it the normal way should work: simply open iTunes, plug it into the computer, and check for iOS updates.

Once you do that, actually, you won't ever need to plug it in to update the system again! :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.