Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Whenever I try emptying my Trash, the progress bar freezes at a specific point. I narrowed down the problem to a folder containing a mercurial repository:

localhost:~ dennis$ cd .Trash/Mercurial.1/xardias_cfg/.hg/store/
localhost:store dennis$ ls -la

The last command does not do anything. It just blocks and does not return to the shell. Removing the folder has the same problem. Trying to send CTRL-C to the process does not do help either.

Disk verification in the disk utility does not show any errors.

Does anyone have an idea what might be wrong or any directions how I can find out?

Thanks a lot! Dennis

PS: It might be worth mentioning that the drive is a 240GB Kingston SSD drive.

share|improve this question
add comment

1 Answer 1

Try running this command:

sudo rm -rf ~/.Trash/*

It will prompt you for administrator credentials. This should force the removal of all files in the trash. Good luck!

If this doesn't work, try booting into Single User mode and doing the following:

  1. Run unmount -uw /
  2. Run rm -rfv /Users/~/.Trash/* (but replace ~ with your username). Note: I added the verbose switch so you'll be able to see what it gets stuck on if it still gets stuck.
  3. If it still gets stuck, notate the file that it hangs on and report back.
share|improve this answer
    
This has the same problem as before. I tried to delete the specific folder using sudo too: –  Dennis Kempin Feb 22 '12 at 0:47
    
No matter how I try to access this folder. The program freezes. –  Dennis Kempin Feb 22 '12 at 0:47
    
I've edited my answer with another suggestion –  Matt Love Feb 22 '12 at 1:16
1  
Thank you very much Matt! I have been drilling it down to one single file and moved the containing folder to a new place. When looking into the folder in single user mode the file was gone. Mysterious. With that file gone my Trash can be emptied now! –  Dennis Kempin Feb 22 '12 at 1:38
    
Glad that worked for you! –  Matt Love Feb 22 '12 at 18:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.