Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Safari has suddenly started showing some strange GUI colors on the bookmarks screen. They seem to have started shortly after applying the latest iTunes update, although not IMMEDIATELY after (a few hours, and only after rebooting my machine). This is what it looks like now (I have not changed any settings): alt text

Is there a way to make it appear normal again?

EDIT:

I have uninstalled, rebooted, and even tried removing all apple settings from my "AppData" directory. Nothing is helping so far.

share|improve this question
    
Is Safari the only app that does that? –  Martín Marconcini Nov 24 '10 at 16:30
    
Yep. The only other Apple app I have installed is iTunes, and it appears to be unaffected. –  Nippysaurus Nov 24 '10 at 21:36
    
Did you ever get this resolved? –  jmlumpkin Jun 1 '11 at 12:05
    
Nope. I've been using IE since the problem started, and today is actually my last day at that job so it will be uninstalled. I guess we will never know what the issue was :( –  Nippysaurus Jun 1 '11 at 21:43
    
figured out a fix - answer coming soon –  jmlumpkin Jun 6 '11 at 13:39
add comment

3 Answers 3

up vote 0 down vote accepted

Its due the the color management profiles on various screens. A fix can be found at http://support.microsoft.com/kb/939395

  1. Click Start, type Color Management in the Start Search box, and then press ENTER.
  2. In the Color Management dialog box, click to select the Use my settings for this device check box.
  3. In the Profiles associated with this device list, click the color profile that you want to remove, and then click Remove.
  4. Note If you receive a warning message, click Yes.
  5. Close the Color Management dialog box and then restart the computer to apply the setting.

I also found if you just delete the other one, then re-add sRGB IEC61966 2.1, and set it as default, you don't even have to reboot and it just works. and it solved the same issue I was seeing in other Applications, but mostly Safari

share|improve this answer
    
I haven't tried this, but its as close to an answer as I think we will get. –  Nippysaurus Jun 14 '11 at 6:42
add comment

I don’t have a lot of Windows Expertise, but I assume that uninstalling Safari (and iTunes) and try installing them from scratch (after a nice reboot), might fix it.

share|improve this answer
    
See my edit to main question. This did not help. –  Nippysaurus Nov 24 '10 at 21:37
add comment

I'm not a Windows 7 user, but I'd guess Safari is inheriting these colours from your appearance settings in your control panel, especially if you've deleted AppData/reinstalled.

Have a try playing with your Display Control Panel (especially the window appearance settings) to see if that fixes things, maybe Safari is using non-standard windows' colours for its bookmark background.

Windows XP's Advanced Appearance Window:

Windows XP's Advanced Appearance Window

share|improve this answer
    
My Windows configuration is set to the default colours, and resetting them does not seem to change the Safari colurs. Thank you for the idea though :) –  Nippysaurus Dec 6 '10 at 2:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.