Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

In a nutshell, I believe I'm having issues configuring iOS to connect to LDAP on a non-standard port.

I've tried a quite a few different sequences, such as appending the port to the server address, but all to no avail. Has anyone been able to connect to an LDAP that runs on a different port than 389? If so, I would appreciate confirmation that it is possible and steps on how you set things up would be even better.

My LDAP is apacheDS and the port it runs on is not 389, so I'm at a loss how an iPhone or iPad can connect to the LDAP.

share|improve this question

migrated from superuser.com Feb 18 '12 at 18:30

This question came from our site for computer enthusiasts and power users.

    
I have tried to edit the question into better shape. I would leave this question here to see if anyone knows of iOS settings for LDAP. You might ask a question tailored to ServerFault where you ask for setup steps / best practices for configuring apacheDS on non-standard ports for consumption of DS by iOS. I'm fairly certain you'll get some good advice there as well. –  bmike Feb 20 '12 at 0:18
    
how to connect to a ldap server? with openldap? –  user19870 Mar 9 '12 at 9:18

2 Answers 2

To the best of my knowledge, iOS doesn't (as of 5.0) support accessing an LDAP server on any port other than 389.

share|improve this answer
    
Thanks you. I don't know if this is right, but if so, I won't waste more effort, since 389 will connect –  datatoo Mar 2 '12 at 22:40
1  
If only 389 is supported that would be pretty concerning, since it also permits providing a username/password. Transmitting your clear-text username/password seems like a pretty bad idea. Generally ldap on 389 has no encryption. –  Zoredache Mar 3 '12 at 0:08
    
iOS will try and make a connection via TLS (still on port 389) and only fall back to clear-text if TLS isn't supported. –  mjturner Mar 3 '12 at 12:02

Most hostname/address fields accept a port in a standard syntax form. I can't test this as I don't have access to an LDAP server on a non-standard port, but hopefully this works for you:

Note the :5385 is my made up port number, obviously you want to enter whatever your LDAP server runs on. Most fields such as browser address bars and other connection strings accept port designation in that matter, immediately following the hostname or IP address, before any additional information.

HTTP web browsing has an implicit :80 that browsers don't show, ditto for HTTPS and :443. If you browsed to http://google.com:80/, your browser would simply strip the :80 but everything would behave normally.

share|improve this answer
    
so far my experience has lead me to believe that the appended port is not used if you designate it –  datatoo Mar 9 '12 at 14:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.