Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've noticed a semi-handy feature on Apple Wireless Keyboard: quick pressing the caps lock key won't enable the caps lock, it needs a determined push. Benefits are obvious, it prevents accidental all-caps text when you actuALLY INTENDED TO PRESS 'A'.

Is there a way to hack this around? Adjust it or remove it completely? I like the idea, but for me it is more of a speed bump than a seat belt.

I have checked the keyboard preferences and the usability preferences as well. Keyboard delay is off and repeat delay is at minimum. There are no delay on other keys (well, except the eject key, but it requires even more determined press), and there is no delay when turning the caps lock off.

I'm on a Snow Leopard Lion and the wireless keyboard came with the mid-2010 iMac.


EDIT: It seems like the functionality is in the driver rather than in the keyboard itself. When using the keyboard in Windows 7 the caps lock key works in a regular manner. The drivers that Windows uses are standard HID Keyboard drivers provided by Microsoft.

share|improve this question
    
+1 I do that ALL the time (i.e., hit caps lock, though it seems to activate it anyway). Good question. –  msanford Dec 14 '10 at 15:19
    
Wow - the edit on Windows driver! That would be new behavior. When the firmware updater for the keyboard came out - we tested it when paired to windows, when paired to mac and when unpaired - and the sub-second delay to engage the caps lock was present no matter what OS was or wasn't present. –  bmike Aug 10 '11 at 16:45

2 Answers 2

Sadly, ends up the delay is built into the keyboard hardware, so it’s still there even if you remap the Caps Lock key to some other function, such as Control.

share|improve this answer
    
After some desperate Googling I was about to come to the same conclusion; especially one Slashdot article: it.slashdot.org/story/09/08/01/1658258/… made me think it might be coded to the firmware flash. BUT THEN I booted to my bootcamp/windows7 partition and the caps lock key works in a regular manner. So it seems the functionality is in the driver rather than in the keyboard itself. (On W7 the keyboard driver is standard HID Keyboard device -type, provided by Microsoft) –  koiyu Dec 13 '10 at 20:39
1  
@koiyu check this: stumbleupon.com/url/rentzsch.com/notes/applesantiCAPSLOCK and look at the comments, some people have reported the same delay with Linux. Maybe the Win driver is different? Weird. –  Martín Marconcini Dec 15 '10 at 19:05

My main answer:

Apple deems this a feature, as documented in their knowledge base. Apple does not document how to disable the delay.

In my experience, if you remap the caps-lock key on Mac OS X (in System Preferences .. Keyboard .. Modifier Keys), and e.g. map it to Control, then the delay goes away while I am logged into Mac OS X. So as koiyu suggests in the comments here, it seems like there is some variation available between the hardware and the keyboard driver.

Remaining questions:

My own problem is that the delay remains when I boot into Ubuntu Linux, and in that context, even when I remap the Caps Lock key to Control, the delay is still present. So the vanilla keyboard driver provided on Ubuntu Linux still suffers from the delay.

So my questions at this point:

  • How is it that the standard Windows 7 driver has no delay and the Linux driver does have the delay?

  • How can one replicate disabling the delay in the context of a Linux installation atop the laptop?

share|improve this answer
    
(I'm posting my followup questions separately here because I realized just now that the original question here was only asking about the Aluminum Wireless keyboard, while my own problem is with the built-in keyboard on an Aluminum MacBook Pro. A slight distinction, yes, but possibly relevant.) –  pnkfelix Feb 6 '13 at 12:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.