Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My Macbook is constantly losing its wifi connection. Sometimes it has trouble connecting, other times it connects, but I obtain a server not found error. It seems to work reasonably well at work, but it can't obtain a connection at home even when I am extremely close to the router. Until recently, I used to only have wifi connection problems occasionally. My android phone seems to be able to connect to wifi without problem.

share|improve this question
    
Try switching the router to another WiFi channel. –  JFW Nov 18 '10 at 14:05

3 Answers 3

up vote 5 down vote accepted
+50

Try using iStumbler to detect and identify neighboring and overlapping wireless access points (WAPs). It's likely an interference issue that can be solved with vigilance. You need to find out what channels your neighbor's WAPs are using, and then switch your router to use the least crowded channel you can find.

Ideally you want to use channels 1, 6, or 11. These are the channels that have the most leeway when it comes to other channels interfering with their signal. Wifi devices operating on a particular channel can interfere with other devices operating on channels up to 5 steps away. The amount of interference grows logarithmically with signal strength and channel proximity.

For example, if you are using channel 1 and your nearest neighboring wireless network is also using channel 1, you are receiving a large amount of interference. If you are on 1 and the other network is on 6, the interference is negligible. However, if you are on channel 1 and your neighbor is using channel 3, you are likely still on the receiving end of a huge amount of interference depending on their WAPs signal strength.

iStumbler will give you information about the signal strengths emanating from the other interfering WAPs, and from there you can infer the best channel to use. You may need to periodically perform the same task as your neighbors change their wifi channels.

share|improve this answer
1  
+1. Make sure you don’t use channels that are not “allowed” in your country. Although some routers block those by default, some don’t and I believe certain channels are not allowed in certain countries. I know that in Spain we can only use a handful of them. Interference is the #1 cause for Wi-fi drops and bad connections. 2.4Ghz (11b/g networks) is the same frequency used by… er… cellphones, microwave ovens, etc. So as you can see, there’s a lot of “talking” going on in that frequency. That’s what made 5ghz the new king of the jungle (and the power of course) –  Martín Marconcini Nov 18 '10 at 10:27
    
Casebash says he's from Chicago, so I stuck with describing channels 1-11 (which are the channels we are allotted in the U.S.). Open sourced firmware usually allows you to switch to 12 or 13. However, not only is it illegal, it will probably not work on any of your devices and freeze your router :) –  Robert S Ciaccio Nov 19 '10 at 4:22
    
@calavera: I'm not from Chicago, I'm from Sydney =P. You must have me confused with someone else –  Casebash Nov 19 '10 at 8:09
    
@casebash: I must've clicked on someone else's profile or totally got confused... happens quite a lot when you have ADHD lol :) –  Robert S Ciaccio Nov 19 '10 at 8:51
    
hah i think i clicked on garikapati's profile :) –  Robert S Ciaccio Nov 19 '10 at 8:52

If you are certain that your Wi-Fi connection works fine when you are somewhere else, there might be signal or compatibility problems between your router and your Macbook Pro. Contrary to popular belief, wi-fi connections are not a voodoo thing, and they just involve radio waves, just like a cellphone and any other wireless device.

Reasons for a Wi-Fi connection being lost could be quite a lot, but usually interference and signal noise are the two primary factors. Where some devices are able to “maintain” the connection (despite the possible errors), others simply fail and drop it more often.

Wi-Fi is designed to continue working despite “small interruptions” (albeit with a decrease in performance due to ‘retries’), but sometimes this is not possible and connections get dropped.

Sometimes the problem relies in the encryption. When the network is not open and it’s traffic is encrypted, this “overhead” causes more drops than the usual.

Possible solutions are resetting the router to factory settings and reconfiguring it, changing the channel from Auto to something allowed in your country, making sure your Operating system / Computer has the latest drivers/patches/etc. and there isn’t really much else you can do.

You can try moving your router to another physical position.

I’ve read a few posts about that specific router model and Macbooks having problems, so also assume there might be a problem with that model (or some revision of the router) and OS X.

You can always try to see if the Console has some relevant error messages (/Applications/Utilities/Console.app).

share|improve this answer

I also have the same issues but with WRT160N.. I will try to reset it to factory settings and will test it again.

@Martin Thanks for the answer, I have one Q. I setup my router when I had a Windows Laptop, then I moved to new place and bought MacBook. Is reset thing is same both pn PC & Mac ?

share|improve this answer
    
@garikapati yes, there is no difference in setting up the router from a Windows machine or a Mac. You will just connect to the router using Safari and it should all be nice and happy. –  Martín Marconcini Nov 18 '10 at 10:25
    
Is that an answer to the question? –  Jefffrey Nov 18 '10 at 19:02
    
I just reset my router(WRT160Nv2) and updated the firmware on it. There is not much changes to my internet speeds, but will be testing the Wi-Fi connectivity from my MBP. –  garikapati Nov 20 '10 at 5:52
    
@garikapati let us know how it went :) –  Martín Marconcini Nov 23 '10 at 14:10
1  
@garikapati - if you're still having trouble, your best bet is to create a new question that covers just your issues. –  Dori Dec 1 '10 at 5:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.