Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Before, with MobileMe, I was able to backup and access my Time Capsule anywhere in the world because I had my MobileMe login stored in my Time Capsule, and my MobileMe entered into my mac.

So when I was at home it would backup through the local network and when remote it did it through the internet.

Once upgrading to iCloud this broke (even though I entered my iCloud info into the time capsule).

Apple apparently fixed this with an update:

The latest Airport Base Station Update 7.6.1 "provides support for remote access to an AirPort disk or a Time Capsule hard drive with an iCloud account."

However, I'm still unable to do it. Is there instructions some where on how to do it with the latest Airport Utility / iCloud?

Note, yes I could do it with port forwarding but that would require that I have a static IP and like most all residential users I don't have a static IP and can't afford to pay 180+ for a business account to have one. And yes, you can use something like DynDNS but that only works if you have an extra computer at home and that its always on. I only have one machine and its my laptop that I bring with me. MobileMe acted like a DynDNS on the Airport to make Back2Mac work and supposively iCloud should do the same.

Also in Airport Utility next to my iCloud login it shows a green icon (so it's connected).

Thanks in advance! MacBook Pro (15-inch Late 2011), Mac OS X (10.7.3)

share|improve this question
    
Got it working finally. Disabled the firewall, and under file sharing on my mac added a user (me). Not sure which of those two solved it by now when on an external network under share in finder it shows the Time Capsule. Very slow, but works! No DynDNS needed. –  cchiera Feb 15 '12 at 2:57
4  
Please post that as an answer so you can mark this problem as resolved. –  sudo rm -rf Mar 24 '12 at 18:14

2 Answers 2

Make sure that you have a clear path to the Internet in terms of firewalls, and ensure that TCP port 5354 and UDP ports 4500 and 5353 are open and unrestricted.

Once you've done that, make sure you are logged into iCloud on your computer, and that the remote Time Capsule is on (also making sure those ports are unblocked on that end). Your disk should now show up via AFP in the Finder sidebar!

Also try these steps from the Apple Support Article about troubleshooting Back to My Mac.

  • Update all your Macs to OS X Lion v10.7.3 or later (OS X Lion v10.7.4 or later is recommended).
  • Choose System Preferences from the Apple () menu. Open iCloud System Preferences and check that Back to My Mac is enabled. See if any diagnostic messages are provided under the Back to My Mac section to assist you with troubleshooting and resolving any connection issue. 
  • Toggle Back To My Mac off and back on by deselecting and then reselecting Back To My Mac in iCloud System Preferences. 
  • Make sure the computer you are trying to connect to is not sleeping and is set to Wake on Demand. For more information about Wake on Demand, see this article.
  • If you are using an AirPort base station, make sure your firmware is up-to-date (open AirPort Utility 6.0 or later).
  • Check your network for a multiple NAT setup and reconfigure your network as needed.
  • Make sure NAT-PMP or UPnP is enabled (if you are using an AirPort Extreme Gigabit Ethernet base station, click here for information about AirPort Extreme Gigabit Ethernet and NAT PMP).
  • Ensure TCP port 5354 and UDP ports 4500 and 5353 are open on your firewall. To learn more about ports used by Apple products, click here.

Note: Perform these steps only if you've verified the information in the previously listed troubleshooting section is configured correctly.

  1. Open Keychain Access located in /Applications/Utilities.
  2. Choose the System Keychain in the Keychains list on the left.
  3. Sort the Keychain list by Kind.
  4. Select all keys listing the "Back to My Mac Key."
  5. Delete the selected keys. You will be prompted for your machine's administrator password.
  6. Quit Keychain Access.
  7. Choose System Preferences from the Apple () menu. Open iCloud System Preferences.
  8. Toggle Back to My Mac off and back on again by deselecting (if still selected) and selecting the checkbox.
  9. Once Back to My Mac connects, quit System Preferences.
share|improve this answer

This works for me in several network configurations. Have you ruled out other things on this specific network that might be causing you to not access the router?

Firewall, IP address problem, routing problem, etc...

share|improve this answer
    
bmike, see @heavymark's comment on the question. He resolved the problem already. –  patrix May 14 '12 at 14:59
1  
I know - but the point here is to have answers in the answer bin. I'd rather the OP or anyone else step up and answer it. Jepoardy questions are OK - better than having it "unanswered" since someone new to the site won't know to look in the comments to "find the answer" –  bmike May 14 '12 at 15:03
    
Also - I'm answering in more general terms. Yes this one person had a firewall issue, but for the benefit of someone with the issue - it seems worth noting that this does work in general and list the three main things that I have seen break it of late. –  bmike May 14 '12 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.