Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a DR-BT50 bluetooth headset (they are headphones) that I want to use with my MacBook unibody. I didn't use to have any problems, but as of recently I am running into gaps/skips in the sound. This happens mostly in third party music players (including flash/youtube videos) although I see it in iTunes, just less often. I know my headset is ok, because it works perfectly with my phone. Also, interference is unlikely the problem, since the headset works well with the phone one foot away from MacBook, and one would think that whatever is interfering with the computer talking to the headphones would also mess with the connection to the phone. Anyway, I know it's a Bluetooth issue because I have absolutely no problems with wired headphones. That said, I have no idea where to start debugging it. I played with all the Bluetooth options I could find, and reset everything to factory defaults (erasing all devices and re-pairing) yet to no avail.

On top of this, maybe related or maybe not (this is an older problem) the Bluetooth audio connection sometimes becomes "garbled". What I mean by this is that, whenever music is playing on the computer I just hear crazy digital noise on the headphones. No errors, no nothing, just continuous garble. I have to turn off Bluetooth on the computer and re-connect to make it go away.

Is there anything else I can do, or am I stuck with using wired headphones with my MacBook?

share|improve this question
1  
I experience exactly the same cracking clicking sounds when using my bluetooth headset (Sennheiser MM-450x) with my MacBook Pro and MacBook Air. It works flawlessly with my iPhone. I wondered if this might be because of the aptX codec? On the iPhone a different codec is used, as far as I know. Does anybody know how to choose the codec being used on a MacBook? – user40900 Feb 1 '13 at 13:02
    
My device is a hifi system and pairing it again and restarting both the BT service and the device seems to solve the issues so far. Hopefully for good – Nikolay Spassov Dec 19 '15 at 20:20

The best step to isolating your issue would be to collect some data about the bluetooth environment where you are using your mac. Radio waves come and go with other devices, new phones, degrading antennas and changes in bluetooth firmware.

The Bluetooth Explorer is the best tool I have found to troubleshoot bluetooth hardware and data. It's free as part of Xcode from the Mac App Store.

You can debug data issues, see the protocols that connected devices are using, and get to all manner of engineering data relating to bluetooth such as errors, relative signal strength indication (RSSI). It's hard to tell if this will help you, but it lets me know when a microwave or home phone was causing noise issues on several occasions when my hardware was otherwise working properly.

Connection Quality Window

share|improve this answer
    
How would I use this tool? Like I said in my post, I'm pretty sure that the problem is not caused by outside interference: the headphones work flawlessly with my phone in the exact same place where they fail with the computer. The link quality, in my case, drops every time the sound breaks, but I have no idea why or how I would fix it. – vlsd Feb 27 '12 at 18:52
    
You would need to explore the application and learn how to read the bluetooth error logs it can provide, rule out interference with measurements (although your hunch may be correct that it's unrelated to signal or noise), and generally just start isolating things one by one until you determine the culprit. Troubleshooting is as much art as it is following a process or finding someone else's list of things to check. – bmike Feb 27 '12 at 19:08
1  
There are no errors. The link quality just goes down. – vlsd Feb 27 '12 at 23:42

I have also suffered 'popping' and crackling using a Bluetooth stereo headphones on a MacBook Air running Lion. The headphones work perfectly when paired with other devices such as my iPhone 4.

I have had substantial improvement by reducing microphone input sensitivity. Open the 'open sound preferences' submenu under your bluetooth devices, and reduce microphone sensitivity to zero.

share|improve this answer
    
Thanks for your tip, trying it now. My bluetooth audio device is a hifi system, so it makes sense that louder sounds would trigger the mic. Btw I am using a rMBP 2015 with El Capitan. However I started getting problems with stuttering with the same hifi system also on a 2011 MBP after updating to Yosemite. Definitely a software/driver issue (and not hw) it seems – Nikolay Spassov Dec 19 '15 at 19:51
up vote 1 down vote accepted

OK, so after a whole lot of debugging and reading internet forums, I came to the conclusion that this is a hardware issue. Apparently the bluetooth cable/antenna in a 2009 unibody macbook is inside the screen assembly, on the same cable as the iSight. A while back I replaced the LCD, so I must have nicked the cable/antenna while doing this. I am not opening the display all over again just to fix this, I just got a bluetooth dongle that works flawlessly --- that's how I know it's not a software problem, since I'm pretty sure OS X uses the same bluetooth stack for both transmitters.

share|improve this answer
    
You should accept this answer so that future viewers know that this is the best answer. – CajunLuke Jun 5 '12 at 20:45

My bluetooth audio over AptX was choppy, too. This fixed it for me:

defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" 53

Another great hint I found is to alt(option)-click the bluetooth icon on the top menu bar of os x: Then navigate to the bluetooth music device on that menu and it will show you the type of codec being used (atpX in my case).

Thank you bmike♦ for the hint to using Connection Quality Window of Bluetooth Explorer! Thanks to it, I was able to determine what's the best position for my bluetooth audio receiver[1]. Surprisingly enough, the best position was on one of it's narrow sides! The position that it is designed to be in doesn't actually give the best RSSI :P

[1] ProCaster Bluetooth Audio Receiver BT-02

share|improve this answer
    
What's the default value for com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" ? – surfrider Jun 1 at 6:37

Run all the related processes on a higher priority:

I made a script to do that: https://gist.github.com/redolent/61e5db9d9685689e21e7

#!/bin/bash

list="$(
    sudo ps -A \
    | grep -iE '([h]ear|[f]irefox|[b]lue|[c]oreaudiod)' \
    | cut -c 1-90
    )"


pids=$( cut -c 1-6 <<< "$list" )


echo sudo renice -5 $pids
sudo renice -5 $pids
share|improve this answer
    
I'm using Hear and Firefox. – redolent Apr 15 '15 at 20:52
    
Interesting, initially it seems to mitigate the issue. rMBP 2015 here, El Capitan. Doesn't solve it completely though – Nikolay Spassov Dec 19 '15 at 19:54
    
If you renice a web browser, make sure you only have one tab open in that particular browser. (For example, I use Chrome for browsing, and Firefox for Pandora) – redolent Dec 19 '15 at 23:47
    
@redolent Is the Firefox this for a certain special addon that only works in Firefox? I only use Firefox, but when I thought about moving to chrome, Pandora started playing odd songs that were trying to sell me stuff :) – Michael Ozeryansky Jan 2 at 23:52
    
No, I use Chrome and Safari mainly, so Firefox is convenient to only use for audio playback. – redolent Jan 3 at 2:42

I have similar problems with my Imac mid 2015 with El Capitan, connected to a Marshall Woburn.

The strange thing is when the Mac is just showing the finder it works perfect. But as soon as I have Safari or Chrome open (doing nothing at all) it starts falling appart.

I tried changing the bit rate as proposed, but even at 53 I see no difference. Do I need to reboot afterwards ? Do I need to run it with sudo or is an admin account enough ?

One strange thing that I noticed is that the Woburn is using the SBC encoder while it supports aptx. Is that normal ?

share|improve this answer

Try this:

  • Disconnect the bt-keybord, the bt-trackpad, the bt-mouse and all the other bluetooth devices one by one while listening the bt-speakers.
    (While doing this, in my case, I discovered that the bt keyboard is interfering, and when I disconnect it, I start hearing the bt speaker working fine.)

  • Then, re-connect the bt devices one by one, and you may see that things continue to work fine on the bt-speakers.

I don't know exactly what happens in my case, but maybe, the bt-keyboard reallocate itself to another "free channel" or something that does not interfere with the already connected bt peripherals.

This solved the problem for me.

I suspect that also the wifi may cause interferences, so while trying to find the responsible of the issue, you may also try to disable the wifi devices while listeing the bt-speakers to identify the guilty device.

share|improve this answer

I have the same issues and have determined that the bluetooth antenna location in my mid 2012 MB Pro is the culprit. I have an Apple BT keyboard and Apple BT Magic Mouse. It is not capable of streaming the BT audio satisfactorily to my 3rd party BT speaker. I've attempted to back off both the keyboard and mouse, but alas, this defeats the reason for them.

Interestingly enough, I'm able to stream beautifully to the 3rd party BT speaker with either my iPhone 5s or my mini iPad. This is the case whether I have WiFi enabled or not.

Nasty flaw in El Capital 10.11.5

share|improve this answer
    
Welcome to Ask Different! Please refrain from adding comments in the Answer section, this is for answers to the questions. Once you have sufficient reputation you’ll be able to add comments and ask follow-up questions. To gain reputation, answer questions that are clear and concise. - From Review - – fbara 2 days ago
    
This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review – Allan 2 days ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.