Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Thinking of buying a used Apple MacBook and wanted to know the best way to tell based on the hardware specs provided by Apple online by entering in the serial number for the MacBook here:

After pulling up the specs for the hardware on Apple, how do I figure out what the feasibility of running a newer version of OS X on that used Mac is?

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

As long as it is a Core 2 Duo processor or better (read: 64-bit architecture), you can put Lion on it. The sole exception seems to be early 2006 model with an Intel Core Duo (32-bit); this one will only support Snow Leopard.

Reference: http://en.wikipedia.org/wiki/MacBook

share|improve this answer
1  
Actually 32 bit intel processors CAN run lion, they're just not supposed to by restriction set by apple, which can easily be changed by editing this once text file inside the installer of lion. –  XAleXOwnZX Feb 12 '12 at 17:10
add comment

As long as you have minimum 2 GB of ram, sufficient disk space, and any mac within the past few years (mine is almost 3 years old running lion like a charm), you'll be fine. 4Gb of ram REALLY helps though.

share|improve this answer
add comment

What do you mean by how will the hardware respond? If you're trying to install a previous version of os x on a mac that shipped after lion shipped, you won't be able to. You can only revert back to the version of os x a mac came with.

The reason for this, I believe, is old versions of os x won't have newer firmware and drivers for new machines.

share|improve this answer
    
+1 @W Dyson: By how will the hardware respond, I mean if I plug in a serial number for the MacBook into Apple's specs page and look at the hardware specs returned, how do I relate those specs to what version of OSX the hardware is updatable to; meaning the highest version of OSX the hardware will support. I am not looking to install an older version of OSX than the one originally shipped with the hardware, only a newer versions. Let me know if you have any other questions. Thanks! –  blunders Feb 12 '12 at 16:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.