Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My friend used to have an iPhone 3GS with iOS version 5. Our text messages showed up blue being that we were on the same software. She now has updated her phone to a Galaxy S II and my phone still thinks that her phone number is operating on iOS 5 software. Her phone cannot receive messages from my phone, but my phone receives messages with no problem. No matter what I do (even restarting my phone and deleting her and reading her) her text messages are still in blue instead of green. When I send a message, it shows that it's sent but her phone never receives it. It's extremely aggravating.

share|improve this question
    
Take a look at your friend's contact on your phone. Is her number set to 'iPhone' or just 'Mobile'? –  Nathan Greenstein Feb 12 '12 at 4:47
5  
@NathanGreenstein This actually has to do with Apple's implementation of the iMessage protocol. It binds devices/SIMs to their servers (using the UUID from the device and the SIM ID) and doesn't release them easily. The label assigned to your friend's phone in Contacts is purely aesthetic. –  cksum Feb 12 '12 at 6:08
    
She's marked as "Mobile" I guess this is a known problem with apple. It's extremely irritating to be dealing with since she's the main person I talk to and I can't text her with my regular SMS. –  Brittany Haight Feb 12 '12 at 20:30

6 Answers 6

This is a known issue with iMessage. In your case, what has happened is that the SIM was registered on Apple's servers as capable of accepting iMessages. When your friend swapped phones, they likely kept the same SIM card. So now their old iPhone (bound to Apple's servers by its UUID) and the SIM card (bound by its own ID) are both registered with Apple to receive iMessages.

This article talks of possible fixes, and the possibility that Apple has something cooking (after all they should provide some capacity to remove the devices, perhaps from your Apple ID account). You can also head over to this article for additional reading and perhaps more solutions.

I wish I had a simple solution for you, but it may require calling Apple and discussing the matter with them. I would say you should also ask them to cover the cost of a new SIM should your friend require one.

share|improve this answer
    
Your SIM card has nothing to do with it. When you turn on iMessage on an iPhone it registers the phone's phone number with Apple as an eligible address to receive iMessages. It's for this same reason that messages sent to your phone number can also be received on a Mac. For instance, I just switched to an Android device, and kept the same SIM card, but switched off iMessage on my iPhone before getting rid of it. As a result I've had no complaints of people not being able to message me. Their iPhone first tries to send as an iMessage, fails after a few seconds, then sends as SMS. –  Mr Rabbit Jun 12 at 14:07

Well it is a bit of a heavy handed solution, but if you were to go into Settings -> Messages and set iMessage to off, then all of your outbound messages would be sent as regular old SMS. Your friend would get them then.

share|improve this answer
    
This actually is a great solution if you can leave iMessages off for a few days. The servers will cull devices that no longer are accepting messages so the more iMessages that get sent to a device that isn't running, the larger a chance Apple will delete the mapping on the server end. This isn't a problem for people that want messages since turning it on again will re-register that device and that's something that won't happen in this case. –  bmike Oct 15 '12 at 14:34

If your friend has registered her iPhone with Apple in the past, she can unregister it on the My Support Profile website.

This article (How to turn off iMessage without iOS device) on Apple’s forum pages implies that this device is then also removed from iMessage, the original problem being:

My iPhone got stolen, but when my friends message me their phones keep trying to send me iMessages.

Good luck!

share|improve this answer

Having similar issue between droid and iPhone… Cannot get each others texts. We both downloaded the app 'WhatsApp' and with a super easy set up we are now able to text without any issues. We can send photos and the app even says you can make calls with it. Its a quick, easy fix to this problem. So glad we found it!

share|improve this answer

I had come across this issue regarding the same phones. We figured out that, because the old iPhone was switched on, my iPhone picked up on iMessage, once we turned the iPhone off as It wasn't needed then the Samsung S3 recieved all msgs as a normal text.

But if you have sold your iPhone, and not deleted your iTunes account, this will not work. You will need to delete your account. If for any reason you don't wish to do this because you have other apple products it will result in registering a new SIM -- which takes five minutes once you have a new SIM.

share|improve this answer
1  
I am absolutely not sure you'll have to delete your iTunes account! That would be overkill. Please don't do it. Also, don’t get a new SIM card. I am sure you can de-register the iPhone in question from Apple’s Messages service. –  myhd Dec 27 '12 at 12:18
    
You cannot delete your Apple ID. And there is no such thing as an "iTunes Account." All purchases made through iTunes are done through an individual's Apple ID. –  cksum Apr 27 '13 at 20:03

Check your phone plan with your carrier. My plan is the same one I started with in 1994. Make sure that your carrier does not show text messaging blocked for your account. I finally went to my Verizon store and there was a guy there who recommended the person who was helping me check my account for any blocked services. Apparently my vintage flip phone did not allow texting; as soon as he unblocked my account, I could finally send a text to my droid contacts. I've been dealing with this problem since last August.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.