Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I tried the new version of TextMate (1.5.10, r1616). I noticed that there's a 'Changed' item on the Release notes stating that the keyboard shortcuts to change tabs are now the de facto standand Shift-Command-[ and ].

Now, whenever I have a tab with .tex file open and I try to browse through tabs TextMate executes Insert commands 'Command Based on Current Word' (Command-}) and 'Environment Based on Current Word' (Command-{) from the LaTeX bundle when changing to the next and previous tab, respectively.

So, what are my options to get the situation back to normal? I think I could disable the aforementioned commands from LaTeX bundle with the Bundle Editor, but with a quick look I didn't find them. Are there any other file types beside LaTeX that might cause problems with overlapping shortcuts? Is this overlapping of shortcuts a bug in TextMate? I guess there's no way to change the next/previous tab navigation commands. One obvious solution would be not to update to the latest version.

share|improve this question
    
You might have some better luck asking at tex.se: tex.stackexchange.com –  Juan A. Navarro Nov 16 '10 at 10:13
add comment

1 Answer

In moments, this update was driving me crazy. Luckily, I remembered that the Mac OS lets you customize keyboard shortcuts. So, I opened system preferences > keyboard > keyboard shortcuts --- and restored my textmate tab navigation to how they were previously! Yay!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.