Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My wife's iPhone is playing up. It won't make any noise except for when it revceives a call. Messages, etc. only vibrate. Just now it made the unlock sound when I unlocked it, but I can't get it to make the sound again. When you press the volume keys, the ringer icon appears with no volume bar:

ringer with no volume bar

The lock button was also playing up for about 12 hours. It would randomly press itself, causing the power off slide to appear or the phone to lock randomly. That problem went away by itself.

Also:

  • iPhone 4 with iOS 5.0.1
  • Tried power off and hard reset
  • Silent switch is off
  • Silent switch mutes all sounds when on
  • Bluetooth is off
  • I've cleaned the dock and headphone ports
  • The water damage indicator is red in the dock port and white in the headphone port (caused by baby drool)

Is there anything else software based I can try to fix this phone, or do I have to pay for repairs?

share|improve this question
    
Souns like some major issues, but a quick suggestion and not really an answer, if you have the Apple headphones, what's happens when you use the built in volume controls? –  Stu Wilson Feb 11 '12 at 22:37
    
@StuWilson, I see the same image as above, ringer with no volume bar. –  Hand-E-Food Feb 12 '12 at 21:34
    
then I believe this is a software issue as per Matt Love's answer, if it was hardware I'd expect the headphones would have worked. –  Stu Wilson Feb 12 '12 at 21:39

2 Answers 2

It's clear that it's not a hardware issues since the sound works in certain scenarios. It seems to be a software based issue. I would suggest backing up and restoring the device using these steps. Make sure you set it up as a new device so as not to transfer any old software back to the phone after the restore.

share|improve this answer
    
I can't get that link to work, but I can imagine what it says. I'll give it a go. –  Hand-E-Food Feb 12 '12 at 11:56
    
Sorry, it's support.apple.com/kb/ht4137 In my time at the Apple Store I've seen this fix for your issue dozens of times. Good luck! –  Matt Love Feb 12 '12 at 12:20
    
Oh, and it looks like Apple's support page is temporarily down, which is why it's not working. –  Matt Love Feb 12 '12 at 12:20
    
Got the page now. I'll try this out next chance I get. Thanks! –  Hand-E-Food Feb 12 '12 at 21:44
    
Didn't fix it. In the end, we paid the replacement fee for a new iPhone. –  Hand-E-Food Nov 20 '12 at 2:40
up vote 0 down vote accepted

It seems that the hardware in the docking port was damaged. The phone thought there was an accessory permanently plugged in.

Also, my wife subsequently managed to smash the screen.

We paid the replacement fee for a new phone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.