Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am laying out a long document in Pages '09 v4.1 (923), using the "Hoefler Text" typeface for the body text. On certain characters (k, e, and others) at the end of an italicized word, the advanced type features of Pages use the swash variation of the last character, though there is an otherwise "normal" italic of the letter. My client does not like the look of this, and I'm looking for a way to disable this behavior.

I have tried going to the Font panel, click on the gear to select Typography, and there are Smart Swash options shown in the window that appears. However, no matter which swash options I enable or disable, Pages seems to ignore them, and continues to add the swashes.

How can I disable these swashes?

Clarification: This happens at the end of an italic span, not for letters that may end a word inside the span; and the span is often in the middle of roman body text. For instance:

screen cap of italic swash behavior

Note the swash on the end of the 't' in "not" and 'k' in "Trek." Not also how in the last line, the 'e' in "stare" gets no swash, but the 'e' at the end of the italic span, in "Trekkie," does.

share|improve this question
    
An acquaintance suggested that I could add a zero-width space character after the italics to stop this behavior, but Pages seems to treat a zero-width space as a normal-width space and, while removing the swash, also disrupts the flow of text with extra spaces, which is unacceptable. –  bobtiki Feb 11 '12 at 21:35
    
And the "zero-width" space is the only character I found that stop this from happening. You could use if for when the italic run is followed by a space anyway, but it's wider, a hassle to insert, and still doesn't solve the issue with punctuation (at least the ?, because the . can be italic too). –  Daniel Beck Feb 11 '12 at 22:00
    
You could try to edit the Hoefler Text font and make the zero width space actually zero width. I have no idea how that works though. –  Daniel Beck Feb 11 '12 at 22:10
    
Sad to admit I gave up. Issue solved by switching to a different typeface that did not exhibit this behavior. Thanks for the help. –  bobtiki Feb 15 '12 at 3:19

2 Answers 2

You cannot disable these swashes using the Smart Swashes section in the Format » Font » Show Fonts » Typography… window, because they're not Word Final Swashes. Those are disabled by default anyway.

What you're seeing are Line Final Swashes, applied only to the end of a line or a text run with consistent formatting.

enter image description here


I found no option to disable them from the Typography window or any menu option.

What seems to work is to end a line by pressing Shift-Return instead of Return.

enter image description here

Note that this will not end the paragraph and allow you to apply a different paragraph style to the second line, so depending on your circumstances (e.g. use in Headings), this will not be an optimal solution.

You can, for example, make the next line font size 1 and only insert a single space character. In the following example, I entered a single A character of font size 1 to the next line so it's visible as a black dot:

enter image description here

It's an ugly hack, but it might work for you.

share|improve this answer
    
In a pinch, you could also set the color of your tiny "a" to white. That way, it would not show up at all. –  Synesthetic Symphony Feb 11 '12 at 14:26
    
@SynestheticSymphony As I wrote just before that, a space character also works. It's somewhat cleaner than adding real text (who knows where that'll show up). The A is just for illustration, that the additional line isn't too apparent. –  Daniel Beck Feb 11 '12 at 14:27
    
Unfortunately, as clarified above, most of my italics are contained within a block of body text, so the shift-return trick won't work for my needs. –  bobtiki Feb 11 '12 at 21:40
    
Oh, you are right. I feel silly now. Should I delete my comments due to irrelevance? –  Synesthetic Symphony Feb 11 '12 at 21:47

The new Hoefler Text that comes with Mountain Lion doesn't have this problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.