Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I maintain a SuperDuper! clone of my primary boot drive for backup purposes. When it's mounted, Finder's "Open With" menu shows duplicate applications. When I unmount it, they go away.

How do I configure OS X not to show applications from external drives in "Open With"?

enter image description here

Note: there is a related question involving duplicate "Open With" items. However, it's not related to external backup drives and its answer -- rebuilding the LaunchServices database -- does not solve my problem.

share|improve this question
    
Just eject it. And leave it unmounted. –  Sean Moubry Feb 10 '12 at 14:16
add comment

1 Answer 1

up vote 7 down vote accepted

You can prevent the applications on your external drive from appearing in the Open With… menu by preventing Spotlight from indexing the drive.

To do this navigate to System Preferences > Spotlight. Select the Privacy tab and add your external drive to the list. Mutineer in the screenshot below is my SuperDuper clone drive.

enter image description here

Update: My best recollection is that this was all I did to solve the problem, but if the problem persists, two additional steps may be necessary:

Make Launch Services reload the list of available apps with the command /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -all local,system,user. As apps on the second drive are not available via Spotlight anymore, the new database will only contain those on your main drive.

Restart Finder to rebuild its Open With context menu (Option-right click on its Dock icon to get the restart option, or do killall Finder in Terminal).

Credit to @kopischke for providing this concise answer on SuperUser.

If you want to avoid the terminal incantations, you can use Onyx to rebuild the spotlight index and launch services database.

share|improve this answer
    
This does not work for me. Actually, I opened Spotlight preferences to find that my clone drive had already been added to this list. I guess I had tried this technique before at some point. –  Sean Moubry Feb 11 '12 at 1:26
    
In that case you may also need to refresh the Spotlight index too. –  jaberg Feb 11 '12 at 16:15
    
…and I've expanded my answer to include the additional steps. I don't recall doing this, but I originally faced the issue years ago and I most likely automatically applied the "shortcut solution" when I replaced my clone drive. Apologies. –  jaberg Feb 11 '12 at 16:30
    
but then "find" (files and folders) feature won't work on that external drive :( –  Nimbuz Aug 1 '12 at 7:21
    
Thanks for this! I have a Boot Camp partition, and kept getting Windows apps showing in the "Open With" menu. The partition kept disappearing from the privacy tab, so I added the WINDOWS folder and the Program Files folder instead - worked like a charm! –  Andrew Parker Jan 7 at 2:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.