Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Once every couple of days an application crashes on my MacBook Pro with Lion (10.7.3). It's also running the newer build that's supposed to have fixed these issues (11D50b).

This has been happening to me ever since I upgraded to Lion. I brought the MacBook Pro to the Apple store and the Genius did some tests and said there are no hardware issues. I even did a full clean OS reinstall hoping it would make the problem go away, but it still occurs.

Here's the latest example (below), I just clicked the red "close" bubble in the TextEdit title bar and this happened. But it can be any application that crashes. It seems random.

I've also tried creating a new account to test whether it's something unique to my profile but apps crash there too.

Why does Lion keep crashing apps on me?

Below is the head of the crash log:

Process:         TextEdit [151]
Path:            /Applications/
Version:         1.7 (289.3)
Build Info:      TextEdit-289003000000000~3
Code Type:       X86-64 (Native)
Parent Process:  launchd [123]

Date/Time:       2012-02-09 20:39:25.666 -0500
OS Version:      Mac OS X 10.7.3 (11D50b)
Report Version:  9

Interval Since Last Report:          74970 sec
Crashes Since Last Report:           3
Per-App Interval Since Last Report:  88329 sec
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      20CE4128-76AD-4508-94DE-8AC8C5BB9231

Crashed Thread:  0  Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000010
share|improve this question
Could you put the entire crashing thread into the post? For me at least, everything below "a ton of stuff snipped out" isn't the interesting bit. – bneely Feb 10 '12 at 2:21
Did you apply the 10.7.3 update using the Combo Updater? There were reports of problems from some who used the Delta Updater that was initially delivered bt Software Update. Else, does the problem occur when you use as alternate user account or is it unique to your primary user account? – jaberg Feb 10 '12 at 3:38
@bneely I tried posting the whole thing, but I was limited to 3000 characters so I had to cut stuff out. I guess I cut out the wrong stuff. Will remember for next time. – Robert Hume Feb 10 '12 at 4:15
@jaberg I did all my updates through Software Update, sorry I don't know if it was "Combo Updater" or not. Yes, the problem occurs when I'm logged in with a clean new user account. – Robert Hume Feb 10 '12 at 4:16
I would suggest you first isolate whether the cause is related to the Lion build or something in your user account. Create a new user, log into that account, and do some computing. If things begin to crash, you'll know the problem is systemic and you can take steps from there. If, however, nothing crashes, and things appear stable, then you have at least isolated the issue to your user profile. – user10355 Feb 10 '12 at 4:45
up vote 1 down vote accepted

Not sure if this apply to your case but I had the same problem till yesterday, my new MBP was crashing randomly while using possibly random applications. I have figured it out that its a hardware problem. I had upgraded my RAM from 4GB to 8GB and had a lot of 'invalid address' crashes. I had replaced my memory to the old chips and all is good.

share|improve this answer
Is there anyway to test the ram to see if it's good or bad? Also, this problem only started when I upgraded to Lion -- Snow Leopard had been fine. – Robert Hume Feb 10 '12 at 14:28
You can test RAM from the terminal using memtest, but I use Rember. – jaberg Feb 10 '12 at 15:10
The Genius at the store would have discovered those problems when they tested your machine, which was cleared of any hardware faults. – user10355 Feb 10 '12 at 19:14
Well, I have upgraded my RAM memory myself and when for the first time I've bought the cheapest one it was crashing my machine randomly, today i have changed to a different set of 4GBx2 chips and its all good, so don't be so smart ass @cksum – Kris Feb 10 '12 at 21:51
Calm down. Read the original question. Read it. He took his machine into an Apple Store. They checked the hardware. Go back and read it again. Maybe you missed it. Calm down. No one's attacking you. I miss things sometimes too. – user10355 Feb 11 '12 at 2:21

Yep, your problem sounds just like what a ton of others were having. Re-update using the combo update from the Apple Web site, and that should cure what ails you. Do Not redo your update using your Apple's built-in Software Update.

share|improve this answer
Thanks, I'll give it a try. – Robert Hume Feb 10 '12 at 14:29
If you looked at the version number in his crash logs, you'd have seen that he's already running the fixed build (11D50b). And it makes sense that Apple would have rolled those fixes into their online version rather than further spreading the infected one to consumers. – user10355 Feb 10 '12 at 19:13
@cksum, you're right. Can't believe I missed that. Plus, your solution was spot on. No more helping behavior from my end. – soxman Feb 11 '12 at 6:03
Just FYI, I manually downloaded the combo update and installed it. It's only been a day but no crashes yet. I'll keep you updated. – Robert Hume Feb 12 '12 at 17:27
Very cool. Hope things stay smooth for you! – soxman Feb 13 '12 at 5:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.