Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a CD that when the items are copied to the desktop (OS 10.6) the items are marked as read only. The CD is UDF formatted and I have read the following on another site:

The Mac simply doesn't understand the UDF format which is widely used by many Windows and Linux computers, along with various consumer DVD burners, video cameras and other devices. OS X gets confused when reading files, thinking they have read-only privileges or locked files or different owners, depending on what software was used to write the disc. Other systems don't suffer from this problem because they fully implement the 13-year-old UDF standard, but OS X doesn't.

Is there any way to get copied items to inherit permission of the folder that they are being copied to? I don't want to have to modify permissions everytime files are copied.

share|improve this question
I'm commenting rather than answering because this isn't a complete solution. You can use Automator to create a Folder Action that will act on any file added to a defined folder. Automator allows you to use shell scripts within workflows. You can create a shell script to change permissions that will be applied to any file copied into the folder (or folders) to which this Folder Action is attached. – jaberg Feb 10 '12 at 16:45

One way would be to copy the files from the command line using rsync: It supports a flag --chmod, so you can say, e.g.,

rsync -a --chmod=u+w /Volumes/name-of-the-CD/ /wherever/

to turn on writable flag for the user (you). Beware, though, that rsync takes a while getting used to, especially when recursively copying directories. Whether or not you end the name of the source directory with a slash actually makes a difference …

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.