Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I had a problem a while back where Chrome was working fine but Safari and Firefox were not. This was fixed by unchecking the "auto-discover proxy" box in the network configuration. See my previous question: Why can't I browse the internet with Safari, but Chrome is working?

Today I find myself able to browse with Firefox but not with Chrome or Safari. A select few pages are still working but mostly nothing. Chrome will give me an error:

 Error 7 (net::ERR_TIMED_OUT): The operation timed out.

To help rule out a few things this even happens when trying to browse to my firewall http://192.168.0.1

Thanks for any help in advance!

I'm running OS X 10.7.2.

share|improve this question
    
It seems like this is possibly only affecting sites which use SSL (unforunately this is most of the sites i frequent: gmail, facebook etc) –  Lee Tickett Feb 9 '12 at 22:17
    
I found superuser.com/questions/349740/… but haven't had much luck with the suggestions although they seem to be headed in the right direction (i think a captive portal is responsible for breaking it!) –  Lee Tickett Feb 9 '12 at 22:28
add comment

1 Answer

up vote 0 down vote accepted

I can't be 100% sure which of these resolved the issue but i took these steps and everything is now working (touch wood):

  1. Terminal
    • sudo mv ~/Library/Keychains/login.keychain ~/Library/Keychains/login.keychain.bak
    • sudo mv /Library/Keychains/System.keychain /Library/Keychains/System.keychain.bak
  2. Reboot
  3. I'd now lost network connectivity and wifi wouldn't connect- i think this is because the wireless key is stored in the keychain which i'd "deleted". I managed to resolve this by going to network preferences, wifi, assist-me and stepping through the wizard.
  4. Lastly i ran software update and upgraded to 10.7.3

Voila

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.