Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using OS X Lion. Whenever I wake my monitors, the iChat screen below pops up:

welcome to iChat

When I let my Mac idle, iChat was NOT open. I never use iChat and would really like this dialog to go away permanently. I don't want to use iChat, period. And I certainly don't want to have to quit iChat every time I wake my monitors. iChat is not in my login items, all of the accounts have been removed or disabled, and I don't know of any other setting that might be causing this.

I thought I had licked this problem before, in fact I was so proud of myself (after searching for a solution for hours) that I blogged about it. But alas, after I restarted my Mac, the problem returned.

I don't have Chax installed (this question asked how to get this behavior, the opposite of what I'm looking for).

I'd be quite happy to uninstall iChat completely, if there were a way. I've considered some of these software removers like AppZapper but I suspect they will be unable to remove iChat for the same reason I can't.

My menu bar looks like this.

menu bar

share|improve this question
    
Do you see the iChat status icon in your menu bar at the top of your screen? It looks like a chat balloon with a gray or black outline. If that's there, and you have no intention of using iChat, you should remove it. You can command-click on it and drag it out of the menu bar. –  bneely Feb 9 '12 at 5:48
1  
@bneely no, there is no iChat status icon that I can tell. I have taken a screen shot while this iChat dialog is open this morning right after I woke up my monitors: bertrandaaron.files.wordpress.com/2012/02/menubar.png –  Aaron Bertrand Feb 9 '12 at 12:42
    
What version of Mac OS X are you running? –  MrDaniel Feb 9 '12 at 13:54
1  
Sorry, I did not see the tag. Might not be a bad idea to say what your running though Mac OS X 10.7.2, etc to help trouble shoot. –  MrDaniel Feb 9 '12 at 18:31
    
Sorry I realize you might have been asking for full version info. 10.7.3. –  Aaron Bertrand Feb 9 '12 at 18:31

2 Answers 2

up vote 4 down vote accepted

Do you have webcam on those monitors? Integrated or attached to USB or FireWire hub on the monitor?

enter image description here

share|improve this answer
1  
Well that's an annoying default setting, if that is the case. Yes, I do have iSight connected to one monitor via FireWire. I've already removed iChat so I can't verify whether that was the cause (or if removing iChat altogether will even solve the problem). –  Aaron Bertrand Feb 9 '12 at 21:40
1  
Thank you, this seems to have been much simpler than all of the avenues I had been trying. Since I did not use iChat at all, I had no inclination to go check the audio/video tab. –  Aaron Bertrand Feb 9 '12 at 23:53
  1. Check that there are no start up files with in the following folders relating to iChat in /System/Library/StartupItems or /Library/StartupItems.

  2. I would check to see if there are any launchd Daemons relating to iChat. Assuming your mac was sleeping when you wake it and the monitor. It looks like there might be a way to explain what is happening via a launchd's StartInterval and StartCalendarInterval options.

  3. I would check that there is not anything iChat related in the following directories:

    YourUserNameHere/Library/LaunchAgents Per-user agents provided by the user.

    /Library/LaunchAgents Per-user agents provided by the administrator.

    /Library/LaunchDaemons System-wide daemons provided by the administrator.

    /System/Library/LaunchAgents Per-user agents provided by Mac OS X.

    /System/Library/LaunchDaemons System-wide daemons provided by Mac OS X.

  4. If you still don't see anything in the above directories, lets see if launchctl can provide any more information.

    Open the Terminal application located in /Applications/Utilities

  5. Type in the following command:

launchctl list | grep iChat

Or if you want to see the whole list

launchctl list

If iChat is not running there should not be anything iChat related listed in the launchctl command output above. If there is than it might be a daemon that is restarting iChat when you don't want it to.

Try to remove it by typing something like this:

launchctl remove [0x0-0x123456].com.apple.iChat

Finally, if you really want to you can uninstall iChat by moving it from the Applications folder to the Trash.

But first you will need give your self write access to iChat. You need to bring up the "get info" panel for iChat by right clicking iChat, etc from in the Finder. Click on the lock icon in the lower right, enter admin password. Then under the "Sharing & Permission" section, click the + button and add your user to list, and then give yourself read write access. Now you can proceed and actually remove iChat just like using sudo...

Or the fancy fast "easy" way: sudo rm -rf /Applcations/iChat.app

share|improve this answer
    
Thanks for all the details. I found a few LaunchAgents that were nonsense (like Parallels, which I uninstalled in 2009) but nothing iChat related. Nothing in launchctl either. I think the trash might have been a viable option in previous versions of the OS, but in Lion I get "iChat.app can't be modified or deleted because it's required by Mac OS X." How do I tell "sudo" to a drag operation? :-) –  Aaron Bertrand Feb 9 '12 at 15:11
    
Thanks, that seemed to work to get rid of the app (should have thought of rm -rf on my own). I'll wait to validate for certain until I have a window to restart. –  Aaron Bertrand Feb 9 '12 at 18:53
1  
Thanks again for your detailed answer. This will likely come in handy but it turns out it was that setting that @iskra pointed out. –  Aaron Bertrand Feb 9 '12 at 23:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.