Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I started using Reminders.app as soon as I got iOS 5.0, and for me it mostly works very well. As soon as I got an iCloud account, of course I turned reminder syncing on there as well.

However I soon found that reminder syncing is still quite buggy at this stage. In particular, it doesn't seem to handle moving to-do items from list to list very well. I often got duplicate items and had other problems. (Note: This is not the topic of my question.)

So I finally decided to live without reminder syncing, and just use Reminders.app on my iPhone only. I turned off reminder syncing in iCloud. This did solve the problem with duplicate items, and I'm mostly happy with it.

But... I noticed that Reminders.app still seems to be accessing the network, even though I haven't configured reminders to sync with anything. (I am basing this observation on the little spinner in the status bar at the top of the iPhone screen.)

And whenever it does this, some of the old problems come back -- mostly sluggishness and jerky scrolling, etc.

I have verified that when I put the iPhone into airplane mode, the problem doesn't happen.

Does anyone know why Reminders.app would still try to access the network when iCloud syncing is turned off? What is it trying to do? Any way to turn it off completely?

share|improve this question

2 Answers 2

Settings > Locations Services > Reminders > Off

If this is on, it'll be periodically checking your location, having nothing to do with iCloud.

share|improve this answer
    
That didn't do it. I turned off the location services for Reminders as you suggested, but it still shows the spinner and slows performance. (Besides, I don't have any location reminders set right now.) –  Will Hains Feb 8 '12 at 4:39
    
do those reminders contain any links, urls? –  konqui Jul 13 at 5:22

Try and turn these off Reminders under the following setting pages and see if it helps:

Settings > Cellular under Use cellular data for: (will be a long list)

Might have nothing to do with Reminders trying to connect to the internet, but it's worth a shot:

Settings > Notification Center under Today view:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.