Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Lion doesn't seem to be giving out DHCP addresses when I turn on Internet Sharing. My firewall is off, I create a shared network with no security sharing ethernet->wifi. In Network Preferences the Wifi connection shows as yellow, with a self-assigned IP, and any device I try to connect (e.g., iPad) doesn't get an address. Help!

share|improve this question
I have the same problem :( – Elliot Feb 13 '12 at 4:58
What does contain the field System Preferences > Network > Wi-Fi > Advanced... > TCP/IP on your DHCP server? What is the output of ps ax | egrep '[ /](PID|boo|nat)'? – daniel Azuelos May 12 '12 at 22:28

5 Answers 5

I finally figured it out.

  • You said your Firewall is off. You should double-check. This will definitely cause Internet Sharing to not work. System Preferences -> Security & Privacy -> Firewall.
  • In the "Sharing" panel, change your Computer Name to something simple. Instead of "Elliot's MacBook Pro", use "MBP".
    • Turn off Internet Sharing (if it's on). Make sure you have set "Share your connection from:" to "Ethernet", and "To computers using:" to "Wi-Fi". Change the "Wi-Fi Options..." and save.
  • If that didn't work: Turn off Wi-Fi on your Lion Mac. Make sure you have internet access from Ethernet, and that it works (test a site in a browser).
  • For your Wi-Fi connection, set "Configure IPv4" to "Using DHCP". In the "DNS" tab, delete any existing entries.

Hope this helps!

share|improve this answer
No evidence of the firewall breaking InternetSharing in any way. Moreover this would be a fatal security bug :<. – daniel Azuelos May 12 '12 at 22:32
Turning off firewall solved the issue for me as well, and found others using Google. Thanks for the tip. – Zoltán Ujhelyi Dec 19 '13 at 21:19
A more specific answer: the "Block all incoming connections" advanced firewall option made Wi-Fi sharing not working. – Zoltán Ujhelyi Dec 27 '13 at 10:44

This thread along with helped me.

  1. I turned off all internet connection sharing.

  2. I deleted the following files:

  3. Restarted

  4. Turned on Internet Sharing

This resulted in Internet Sharing sharing giving the client the correct DHCP lease details.

share|improve this answer
This is the only fix that worked for me form the answers here. It might be worth mentioning that you can back up those files before deleting them. :) – Alex Ciminian Jan 23 '14 at 16:18

I'm using it. InternetSharing and Firewall: on do work together. (It's already huge enough a security shame to have to start a wireless network with WEP). Beware: you should not ride the raw Internet with your Firewall: off.

On the other hand I'm also sure of another behaviour. InternetSharing doesn't start bootpd if the network connexion to Ethernet isn't up, i.e. doesn't have an IP valid address. (And bootpd is the daemon which distribute IP addresses on the Wi-fi side).

Within the valid network configuration on top of which you want to build a sharing of your Ethernet connexion,

  • the Ethernet connexion should be marked as green, with a valid IP Address,
  • the Wi-Fi connexion should be marked as yellow, with Network Name: No network selected.

When you start Internet Sharing 2 details will change:

  • the Wi-Fi icon in the menu bar should switch to grey with a white arrow,
  • the Wi-Fi connexion should be marked as green, with Network Name: Internet Sharing: on.
share|improve this answer

This worked for me on 10.9 Mavericks (build 13A598)

  1. Open Terminal and run

    sudo launchctl remove
  2. Re-enable Internet Sharing

This guy below has a basic explanation of what he's doing if you want more of an explanation and debugging process.

share|improve this answer

This issue can also manifest itself when you go to the Firewall Options and Block all incoming connections is enabled.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.