Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

As soon as I restarted the system after installing the 10.7.3 update, my wifi stopped working. It wouldn't connect. It would get a private ip assigned to it.

So, I switched on and off the wifi, changed the network settings several times by removing the wifi and adding it again, restarted the system, and when all of these didn't help, I phoned Apple support. After asking me to fiddle with the router, computer and several other things, he accepted that the new update was having issues. And I needed to roll back to the old version. Has anyone run into the same problem? Is there anyway to fix this?

share|improve this question
add comment

4 Answers 4

Many times the Combo Update will resolve problems. Download that update (on another system if you have to) and install it, then restart. I have not seen generalized WiFi issues after the 10.7.3 update, so it is very likely the combo update will help.

share|improve this answer
add comment

I had the same problem even with the combo update. I was able to find a thread on Apple's support forums that described the solution as turning off and on the OS X firewall, however, after booting from Windows (Boot Camp) back into OS X, I found that the issue had resolved itself without further intervention.

share|improve this answer
add comment

I saw exactly the same report about wifi and 10.7.3 in a greek forum. My opinion, after trying many 'tricks' to deal with this lion problem, is that the only final solution to this problem is to buy an airport express. Since I bought it, some months ago, I can't remember a single problem with the wireless connection between my macbook pro and the airport express. If internet is critical for your job (I am a professional developer) the only 100% solution so far is to buy airport express.

share|improve this answer
    
Airport Express is a nice product; however, I would add that an ethernet connection is far closer to 100% in terms of reliability, etc., than wireless. –  soxman Feb 12 '12 at 5:26
add comment

when waking from sleep tap the power button on the back and it will not lose the internet. Do not touch the keyboard when waking from sleep. This is a temp. fix. Waiting for a solution. Easier than going to system preferences > network> choosing network each time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.