Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I created a new message in Mail with some pictures attached. When I noticed it was more than 10 MB, I didn't send it and deleted the draft. But my settings included "synchronize drafts with server", which I turned off now. Mail.app apparently tries to load the message again and again, and it appears in a local folder (recovered mails) even after I deleted it several times. Meanwhile there are four duplicates of the message with about 45 MB worth of attachments in this local folder.

The worst thing about it: Mail does not get new incoming emails.

What can I do about it?

OS X 10.7.3 and Mail Version 5.2

share|improve this question
    
The same thing is happening to me! I too have a recurring "recovered message" that I can't delete AND it wont load any new mail. It says 'incomming message 1 of 2' but then it doesnt come up :s –  user23680 Jun 6 '12 at 10:26
add comment

4 Answers

up vote 1 down vote accepted

First disconnect from the internet AND quit Mail.app.

Second, click on the Finder icon in the Dock. Choose the 'Go' menu in the menubar and hold down the 'option' key on your keyboard. With the 'option' key held down, you'll see an item in the menu called 'Library' - this is your user library, and not your hard disk or system library.

From this Library folder, you'll see the Mail folder. Navigate through V2/{yourEmailaddress.mbox)> and hunt around for either /Recovered Mail/ or /Drafts/ folders inside. It's in there somewhere. Delete the file or the entire folder if there's nothing else inside that you want.

Once that's done, reconnect to the internet, but do not start Mail. Go to your webmail provider and ensure that the file you found above is not on the server. I know you said you checked that already, but you should check again that there is no 'recovered mail' or you're going to have to start this whole process all over again...

Once that's done, restart Mail and reconnect to the internet.

From the menubar at the top choose Mailbox > Rebuild.

share|improve this answer
add comment

I find that I often have to force quit Mail.app and then problems like this resolve themselves.

Apple has a KB article on How to Force quit that can be found here: http://support.apple.com/kb/ht3411

share|improve this answer
add comment

Try the following:

  1. If you have a webmail option with this account, you might be able to delete the message from there.

  2. Alternately, in the Account prefs under Mailbox Behaviors, uncheck the "Store draft messages on server" option. Restart Mail and see if you can then delete it. You may just have to let Mail run for a while till it loads this.

  3. A third option may be to delete the Drafts folder at ~/Library/Mail/V2/your_email_account/Drafts.mbox. Then restart Mail and it should be recreated. This may only work after #2 above.

share|improve this answer
    
hm well the specific email isn't in any folders but the local "recovery", therefore #1 won't help (checked it, no email online). And I've done #2 already, as i said in my question post "synchronize drafts with server" turned off now. #3... since the email doens't exist in drafts anymore...? Besides I can't find this .mbox files, in my Library there is no folder Mail and searching for .mbox is not successful. –  Alice Feb 4 '12 at 17:20
    
You may just have to let Mail run, let it load and then delete it. Turn off new mail checking during this time. –  afragen Feb 4 '12 at 17:23
    
i'm still waiting... how long may it take? –  Alice Feb 4 '12 at 19:51
    
It probably depends upon the speed of your net connection. Sounds like it'll have to load a lot of data and that will also depend on server's upload speed. –  afragen Feb 5 '12 at 4:25
add comment

You may be able to control what Mail is doing by opening the Activity window. From Mail's Window menu, choose Activity. This shows the tasks that are in progress, and if you see any related to saving, syncing, or duplicating drafts or attachments, hit the red stop sign icon on the right of the applicable row.

share|improve this answer
    
ok I just killed all tasks. But one of them (communicate with server, add new emails) is always coming back and new mails are still not loaded and the local recovery mail is still appearing. –  Alice Feb 4 '12 at 15:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.