Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I set Mission Control to "Show Application Windows" (Expose) with a mouse button or hot corner. Great, it shows all of the windows of the current foreground app across all spaces/desktops.

However, I can't seem to get it to switch to the desktop containing the window I select, making it rather useless. Is there another hidden option to do this? How else are you supposed to use Expose to find app windows across spaces and bring the found window to the front?!

Also it would be great if there were a way to go directly from the Mission Control display (multiple apps, pile of windows, scroll to spread 'em) directly to the Expose showing all of the windows unpiled for the selected app. Anyone?

Seems Apple is about 80% of the way there on this one but despite the fancy graphics is missing the most basic use case. No wonder people want to revert to Snow Leopard.

Update: seems there is a problem with the settings, perhaps due to the system being migrated from a SnowLeopard machine. Creating a new user acct on Lion does not show the problem--Expose works correctly (it switches) for the new user. So, now I've updated the question to "How to reset the MissionControl/Expose/Spaces settings to defaults on Lion?"

share|improve this question
    
It works for me… Also please keep one question per submission. Multiple questions makes it confusing for potential answerers. –  timothymh Feb 4 '12 at 21:44
    
What works for you? Please be precise in your answer. The main question is how to select a window in Expose and have it switch to that desktop and bring the window to the front. That basic function does not work on our pro config. How do you do it? Do you just click on it? –  tribalvibes Feb 4 '12 at 22:07
    
Yes, clicking on a window in another space while in Exposé does switch to that space. I will do some investigating into my settings to try to find anything I may have changed. –  timothymh Feb 4 '12 at 22:09
    
I haven't been able to find anything, and that includes System Preferences and TinkerTool, and TinkerTool System. I can't think of anywhere else I might have changed something, so the fault probably lies in the way you have it set up. –  timothymh Feb 4 '12 at 22:16
    
I tried this on a friend's machine with just a few windows open across two desktops and it worked as expected. On our setup though with dozens of windows and multiple spaces, it does not work. Everything is fast and smooth, it just doesn't switch to the destination window's desktop. It does however bring the window to the front if I subsequently manually switch to that window's desktop. –  tribalvibes Feb 4 '12 at 23:03

1 Answer 1

just go to system preferences click keyboard and disable launchpad and mission control then click trackpad and go to the third tab and disable mission control and launchpad

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.