Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When i plug my cable into my macbook pro it will show the default home screen on the tv but it doesn't show anything from my desktop.

I can swipe over and see one thing from my dashboard but nothing else. What do i need to do to get to work?

share|improve this question

1 Answer 1

When you plug in an external monitor (or TV, etc) to your Mac, it merely extends the desktop area into it, so it can look blank except for your desktop background. You can get it to mirror the display, so what you see on the external screen matches the Macbook itself, but that's not the default option. There are various reasons for this, it nothing else the external screen is unlikely to have either the same display resolution or screen ratio, and so a mirrored display may well look odd as well as being a bit of a waste of the extra space.

So, you should be able to drag your apps and windows into it, although it's guesswork until you configure it whether it thinks that the display is left, right, above or below your existing screen. Experiment by dragging a finder window across all edges, and note when it starts to appear on the TV. The TV might be to the right of your macbook, but it may require pushing content off the left edge in order to use it...

In order to change this, and if you want it to become your main display so that the dock and menu bar and other desktop icons appear on it and don't want to just mirror the display (useful for example when connecting a Macbook at 1280x800 resolution up to a 1080p tv) then open up display preferences from system preferences, where you will be able to identify, position and configure both monitors, and drag the menu bar from one screen to another in order to make it the primary screen.

If you make the TV your primary screen, then unplug it, it will automatically revert.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.