Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am unsuccessfully sending a file from my smartphone Huawei Ideos X5 with Android 2.3.5 to my iMac. I paired the devices successfully. Android phone receives successfully anything from iMac, but iMac cannot receive anything. I disabled my firewall and disabled the stealth mode too but still problem persists.

How can you make iMac able to receive a file by Bluetooth from Android smartphone?

share|improve this question
    
Tell us more about your Android phone. Model, OS Version, etc. –  Martín Marconcini Feb 2 '12 at 5:01
    
@MartínMarconcini It is Huawei Ideos X5 with Android 2.3. - The problem is probably with Mac and its support with Android devices. –  Masi Feb 2 '12 at 10:57
    
Exact Android version 2.3.5, the official release. –  Masi Feb 2 '12 at 10:58
add comment

2 Answers

up vote 6 down vote accepted

Provided you have done what Vlad said (enable the Bluetooth sharing) and paired the devices (which you seem to have done), I have absolutely no problem to send files via bluetooth using my Nexus-S. I have ICS 4.03 now, but I had 2.3.x (where X is 3, 4, 5 and 6 if I'm not mistaken).

Once you have the devices Paired, if the Mac is in range and with BT enabled, the phone can send files because the Mac should be on the phone's list of paired devices. I recall that in 2.3.x sometimes it won't work, but retrying to turning on/off BT was usually enough. I don't use it a lot, but I just tried (after months of probably never touching bluetooth on either device) and I got this:

enter image description here

Here's my preference pane:

enter image description here

and Finally, this is my Phone's paired list (two are intentionally blurred), but you can see my Macbook Air:

enter image description here

Hope you can double-check your settings.

For reference:

  1. I have Firewall ON
  2. I have Firewall Stealth ON.

Here's my Firewall Screen (app list blurred by me):

enter image description here

share|improve this answer
add comment

You need to enable Bluetooth sharing. Go to System Preferences > Bluetooth > Sharing Setup... > check Bluetooth Sharing.

share|improve this answer
add comment

protected by Community Nov 12 '12 at 14:19

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.