Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

After a few days my older emails on iPad2 stop showing in the inbox. Dont find any clue where they went.

Does the mail program store the older emails elsewhere? How can i show all the emails and not just the newer ones?

share|improve this question
3  
What kind of account do you have? Exchange? Gmail? Other? There are specific settings for Exchange mails. –  Loïc Wolff Jan 31 '12 at 9:15
    
Hotmail and my domain account –  miro Feb 3 '12 at 2:55
add comment

2 Answers 2

up vote 3 down vote accepted

Go to:

Settings > Mail, Contacts, Calendars

Scroll down to the "Mail" section and look at "Show." Mine is set to show the 50 most recent messages. Maybe this is why older emails seem to disappear? To test, try setting this to a higher value; it allows you to set it as high as 1000 messages.

share|improve this answer
    
I guess that is the reason. Is there any way i can see the older emails? –  miro Feb 3 '12 at 2:54
    
What happened when you set it to a 1000 messages? Did older emails not appear then? –  james.garriss Feb 3 '12 at 11:53
    
No... Older emails did not appear on ipad –  miro Feb 3 '12 at 16:14
    
First, go to Hotmail via your web browser. Make sure that the "missing" emails are still available there. (If you can't see them there, you won't be able to see them on your iPad.) Second, how are you connecting your Mail app to your Hotmail account? Are you using IMAP? If not, try it with IMAP. That should synchronize your Mail app with your account. –  james.garriss Feb 3 '12 at 16:21
add comment

If you have an Exchange account or even a Gmail account configured as an Exchange account, there is an option in the email settings for Exchange to only sync up to a certain number of days worth of email. By default, it it set to 3 days. You can change this by going to Settings > Mail, Contacts & Calendars, tap on the email account in question and change the "Mail Days to Sync" option from 3 days to whatever you desire (I use No Limit).

Hope this helps.

share|improve this answer
    
Using hotmail and my domain account. –  miro Feb 3 '12 at 2:53
add comment

protected by Community Feb 7 '13 at 11:26

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.