Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've bought an iPhone 4 and the text and calling work fine, as does wifi. However, when trying to use internet without Wifi I get a "Could not activate cellular data network - PDP authentication failure".

How can I fix this?

share|improve this question

6 Answers 6

up vote 3 down vote accepted

There have been a lot of different attempts to fix this general error in different ways. Some of these may work for you.

  • Remove the SIM card from iPhone 3G, turn off the phone, reboot, then reinsert the sim card and wait an hour or two.

  • Go to Settings -> General -> Reset -> Reset Network Settings on your phone to reset the network setting on the iPhone.

  • if nothing else works, call AT&T and have them reset your number.

share|improve this answer
Resetting the network settings fixed it for me... even though nothing changed. Very strange! –  GiddyUpHorsey Nov 11 '10 at 21:05

I just got this problem fixed for Argentina calling t-mobile tech support. They were great.

Calling worked. SMS worked. Data - did not work. APN Authentication Failure

Tried before this - airplane mode - cell settings reset - power cycle (turn off/on) phone - hard reset - network setting reset - several APN profiles (only useful if you change to local SIM card)

The data roaming ON was set on my phone, but that wasn't working on movistar service. They had me dial a special code to turn that on on the network for my line.


And it turned data roaming on and instantly - data was back on.


share|improve this answer

You might also try going into Settings > Carrier and choosing manual carrier selection - bizarrely enough, that worked for me. See http://apple.stackexchange.com/a/52624/12164

share|improve this answer

Try to hard -reset the whole phone using the power and the home button.

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Thecafremo Feb 20 '13 at 14:03

holding both buttons (power and home buttons) at the same time seemed to work for me :)

share|improve this answer

in most cases this error occores due to insufficient credit in you mobile connection. please pay your bill to the service provider and try again. it should work.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.