Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I connect an external monitor to my new MacBook Air via Mini DisplayPort to HDMI, I see the extended desktop but there are snow-like artifacts. When I change the resolution to 720p, the screen looks normal.

I have tried other standard resolutions (1024x768 and higher) with the same effect. I have also tried toggling between 50hz and 60hz, 1080i and 1080p, each of which causes the same issue.

I get the feeling it has something to do with my relatively cheap adapter cable, but am unsure. Thoughts?

share|improve this question
The adapter might be defective. I have an Apple adapter and a similar monitor, and I had a problem similar to this one: ofter I got snow as soon as it was switched on, and after a random amount of time it started working (and never stopped working until it was shut down again). I didn't have this problem at first, and it worsened with time, plus touching/tweaking the adapter sometimes fixed it, so in my case it most definitely was the adapter itself. – o0'. Jul 22 '14 at 17:57

4 Answers 4

up vote 3 down vote accepted

Likely to be the adaptor cable if it's cheap - might not be able to handle the HD throughput (although outputting to HDMI, you'd think it'd be able to).

While this sounds counter-intuitive, try moving around the alignment of the second screen as this might ditch the 'snow'.

Also, have you tried the screen with any other HD inputs?

share|improve this answer
I have two identical displays and both exhibit the same problem. I am unable to manually adjust the picture alignment (with the exception of an overscan setting which has no effect). I've also used my Apple TV (2) on both screens and have successfully played HD video, so the screens are 1080-capable. It looks like it must be the cable. – Paperjam Jan 30 '12 at 22:09
Definitely sounds like crosstalk or capacitive interference in the cable. Since increasing the resolution alters the frequency at which the digital signal is transmitted, this in poorly shielded cables will induce a feedback signal causing strangely interpreted data on the screen – Stu Wilson Jan 31 '12 at 16:43
I've got the same problem with two 13" MBA's in the exact same setup. Both are 2014 models (one i5 and one i7) connected to an ASUS MX279 using an Apple MDP to DVI converter and a DVI to HDMI cable that came with the screen. It only occurs if the screen is turned on before the Mac wakes up. If I hit the space bar to wake up the Mac and turn on the screen five seconds later, no snow. I also tried to use an Apple MDP to HDMI (female) converter with an HDMI cable, same problem. – wout Mar 8 at 8:05

In my experience this can also be caused by something as simple/stupid as having your HDMI cable rolled up. The EM field put out by the signal traveling through the cable can throw off the integrity of the signal itself... so, unwrap your cable if you havent already :)

share|improve this answer

You may have mirroring on.

With mirroring it seems to only match the resolution of your internal display (1440 x 900, native).

This doesn't always scale up the best to a 1920 x 1080 monitor and at 23" you might start to see some pixelation when you zoom in.

I noticed this on my 22" Acer with my 2012 13" MacBook Air.

share|improve this answer

I changed the cable to the monitor buying a £8 ($12) cable from Amazon and it stopped immediately.

The cable prior that I was using was a Belkin one that lasted for 4 years and was 5 times the price, before the snow started and just got worse.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.