Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I "upgraded" from Snow Leopard with Homebrew and vim both chugging along happily, to Lion. Now vim hangs/segfaults, and when I invoke brew, it complains xcode is missing, and continues to do so after downloading Xcode from the app store. I wanted to install vim from source, but that requires Mercurial, which I may be able to use to create a tarball from a Linux virtual machine, but overall Unix-like functionality is broken on Lion.

How can I get Unix acting like Unix under Lion?

share|improve this question
    
Did you do a fresh install of Lion when you upgraded? –  cm2 Jan 27 '12 at 19:13

2 Answers 2

up vote 6 down vote accepted

You may already know this, but downloading/installing Xcode from the app store doesn't actually install it. It just leaves an installer in your Applications folder, which you have to run to actually install Xcode.

Don't know if this is contributing to your problem, but it tripped me up.

share|improve this answer
    
+1, installing from installer now. Not impressed that it's this way. –  JonathanHayward Jan 26 '12 at 21:24

If /usr/bin/vim is segfaulting, you might need to disable your dot files or make a new user to get a cleaner environment.

Have you checked the contents of /Developer/usr/bin to make sure Xcode installed the command line tools correctly?

mac:~ me$ ls -1 /Developer/usr/bin/ | wc -l
     167

Rerunning the latest Xcode installer (4.2 or later) should get the correct binaries in your path /usr/bin as well as the directory listed above with the whole assembly of tools needed for brew and make to work as expected in a traditional unix sense.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.