Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

This problem has been driving me mad for months and started when I upgraded to OS X Lion from Snow Leopard on my iMac.

I've got a Saffire 56 external audio device connected via FireWire (works perfectly / all newest drivers etc). I get crackling, jittery audio whenever Airport decides to scan for networks, or connects to my home network. If I turn it off everything works perfectly.

Why the AirPort and a FireWire audio device are remotely connected I have no idea?

Does anyone have a solution for disabling AirPort scanning for networks, or better still, stop the problem completely?

share|improve this question
    
It sounds crazy even to me, but I would try temporarily shielding the audio unit and cabling with aluminum foil to see if you can determine if the scanning radio waves are being picked up by the audio hardware. You might also try grounding the units better if you are not connected to a good electrical ground. –  bmike Feb 8 '12 at 16:18
    
Curiously enough, this isn't the first case of this. Windows 7 had the same issue with sound (which they subsequently fixed with a patch). I tried all manner of diagnosing the issue for a friend and found out that a patch to the network drivers fixed the problem. To me, this seems like it may be more of an "industry standard" than a Mac thing. Have you tried connecting via a CAT5 (ethernet cable)? It might be a suitable workaround till you can get a proper fix. –  cksum Feb 8 '12 at 22:27

2 Answers 2

up vote 2 down vote accepted
+100

Other than disabling the WiFi card entirely, there isn't a documented way to prevent periodic scans with the Mac OS running.

It's possible that just normal interference like when a mobile phone disturbs a radio is affecting the audio signals. You don't say what Mac hardware you are using, but you could try something as simple as moving the audio hardware further away, or to the other side of your iMac/Macbook etc, maybe even run it through a hub or use a long cable to take it out of reach of the antenna, see if it makes a difference. Failing that try changing the WiFi channels on your router to see if it helps.

The other issue to consider is perhaps the AirPort card is failing or improperly grounded / connected inside the mac. I have seen the antenna cables pop off when a Mac takes a tumble - so if it's not too much inconvenience or cost, having a technician run a quick test on the airport card and verify all the internal cables / grounding is correct might solve the issue as well.

It's entirely possible with Lion that the airport drivers do different things with AirDrop that Windows drivers don't do and that could conceivably be the cause. It's a long shot, but I've seen this sort of thing before.

share|improve this answer
    
Thanks for this, although this is not the case, if I boot into Windows through bootcamp, everything works as expected. I think the only option is to re-install OS X. Something has gone wrong in the upgrade from Snow Leopard –  st3 Feb 4 '12 at 15:56
    
Wow - is it possible to isolate the hardware to determine if the interference is transmitted over radio waves (the audio unit is picking up the radio energy that the airport card is broadcasting) or if the interference / electrical noise is being transmitted from within the mac's circuitry. –  bmike Feb 8 '12 at 16:13
    
The more and more I think about it I think you may be right, it 'feels' like interference when it happens. I will try tonight to move the unit as far away from the iMac as possible. –  st3 Feb 8 '12 at 16:40
    
I think if you have airdrop running, it bangs about scanning channels other than the AP you are currently connected to, and may use a wider frequency range while it's at it. –  stuffe Feb 8 '12 at 16:46

FireWire can be used as an Ethernet interface. I would make sure that you do not have this enabled. Go to the System Preferences -> Networks and delete any FireWire interfaces from the panel on the left.

share|improve this answer
    
Great suggestion, unfortunately it hasn't worked. They were off anyway but I've deleted them to be sure. Still no luck. –  st3 Jan 24 '12 at 20:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.