Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A few days ago, I've installed an additional SSD (as a main system disk) into my 2011 Mac mini (manual installation using Ifixit's Mac mini Dual Harddrive Kit) that first behaved strangely and today failed catastrophically (Disk Utility could not repair it; I had to re-format the whole thing, losing all the data and two days of work).

The SSD is a brand new Intel 510, 120 GB.

I did a SMART parameter check on the drive, and there are no errors or warnings. Currently, I am using Tech Tool Pro 6 (latest update) to do a surface check and find out if the drive has any bad blocks. This will take the next 7 hours. So far, everything is fine.

I am now wondering what could be the problem. If there are unmarked bad blocks on the drive, then that is that and I will have to send in the drive to get it replaced (or do I?). But then again, I have formatted the drive and installed a complete OS X Lion on it twice, and I never got an error. Which is weird if there are bad blocks on the drive, or is it?

As for the weird behavior: I could never boot directly from the SSD when turning on the Mac mini. The mac would then hang before the login screen was displayed. But if I booted first from the factory HD, or the Recovery system on the factory HD, and then from the SSD, everything was (apparently) fine.

I tried intermittently to boot from the SSD in single-user mode (holding Apple-S during boot) and check for any warnings or errors. I got various errors that halted bootup of the system, including kernel extension problems (that apparently caused the keyboard to not be recognized, so I couldn't type aftwards), and the system being unable to mount root. The last time I did this, I got disturbing errors that the Journal could not be read or written back. I guess this was when the drive failed completely. But now that I did a re-boot from the factory HD and re-formatted the SSD (like I said, Disk Utility couldn't fix it, so think I had no choice), it appears to be completely fine.

So, all of this is very weird. I'm asking: does anyone have any idea what could be the issue here? I can only do wild guesses. If it's a hardware failure outside of the SSD (broken S-ATA cable/connector, faulty S-ATA controller), I guess nothing would work at all, so I'm kind of ruling that out.

I've read something about TRIM support and that Apple uses this on its own BTO SSDs. My understanding is that it speeds up bandwidth, but is not essential for operation. I've not touched TRIM settings. Could that be an issue?

Could it be a firmware problem with the SSD? How do I test for this? (Again, I get no SMART parameter errors or warnings, and the surface check so far shows no bad blocks.)

Bottom line, I'm totally confused and could use any hint or help or ideas. Thank you!


  1. I aborted the surface check as the time to finish would just increase continually; it was at 16 hours when I last checked. I tried the surface check with the 500 GB factory harddisk, that would have taken just under 2 hours. So, 2 hours for 500 GB of mechanical drive versus 16 hours for 120 GB of SSD -- there is definitely something wrong.

  2. Someone gave me the hint I should try to clone the working system on the factory HD to the SSD using Carbon Copy Cloner, so I did, and CCC fails after a few minutes of apparently doing nothing, spewing out a load of errors. I then re-checked the drive using Disk Utility, and I got no errors at all. So that is weird still.

  3. I now activated TRIM support using the published kernel extension hack. It works. Tried the surface check again: now just 16 minutes (60 times speed-up). It finished without errors.

  4. Cloning the system from the factory HD to the SSD using CCC now works without problems.

Maybe activating TRIM was the fix. It's confusing because for all I know this is not essential, it only speeds up the drives. However, in my configuration, TRIM appears to be compulsory. Maybe it has to do with S-ATA III and full 6 GBit/s bandwidth – because both the S-ATA controller in my Mac mini and the SSD support it, and System Profiler tells me that it is enabled, too. Timing issues perhaps?

Still, if anyone can add info to this I would appreciate it as I'm still kind of stumbling through the dark.

share|improve this question
If you have access to a win PC I can highly recommend using the Intel SSD Toolbox to do a check on the drive. – Vlad Jan 24 '12 at 15:32
I just activated TRIM support for the drive using the kext patch/hack that is documented everywhere. Now the surface check using Tech Tool Pro takes only 16 minutes instead of 16 hours (it went up from the 7 hours I quoted above). Waiting for that to finish now. Seems to be quite a huge change. – Niels Heidenreich Jan 24 '12 at 16:09
FYI, SMART is useless as any sort of measure. It read my dead drive as green across the board. Activating TRIM is probably what resolved your issue. I would guard against running a surface scan on an SSD, incidentally. No need to wear the bits out faster than necessary. – user479 Jan 24 '12 at 19:40
Thanks Vlad and Randolph. The drive is fine… and TRIM made it much faster, but I still got weird random errors. There might be a problem with the cable, or a cable/driver problem related to S-ATA III (as opposed to S-ATA II). Still stumbling. – Niels Heidenreich Apr 4 '12 at 17:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.