Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I restored my iPad today. The first, say, 30 apps redownloaded fine after the restore, but now my screens are filled with "Waiting..." icons. I've tried downloading something else and entering my Apple ID password, I've tried restarting, but nothing seems to get the other apps to download. What can I do?

share|improve this question
    
Be patient. Sometimes a restart works, sometimes resetting your network connection works. It can take time. –  user479 Jan 24 '12 at 19:42
    
I've tried restarting, and absolutely nothing has happened for the past 19 hours or so, but I'll try resetting the network connection. Thanks for the suggestion! –  timothymh Jan 24 '12 at 20:34
    
That didn't seem to work...I'm going to try reinitiating the restore. I haven't really done anything on it since then, so data loss won't be an issue. –  timothymh Jan 24 '12 at 20:40
    
Re-restoring it seems to be doing the trick. I'll submit that as the correct answer. –  timothymh Jan 24 '12 at 20:59

1 Answer 1

up vote 1 down vote accepted

Plugging it in to iTunes again and re-restoring it did the trick.

share|improve this answer
    
Glad you resolved the problem! –  user479 Jan 24 '12 at 22:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.