Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Looks like my 2nd HDD became a brick. I tried to partition it via Disk Utilities/booted from recovery partition/diskutil to no luck!

I got vague/strange errors such as: unable to unmount, or:

Partition failed with the error:
Wiping volume data to prevent future accidental probing failed.

Is there any way to force the partition process, or somehow revive the hard drive??

Partition failed

share|improve this question
    
Could you specify whether you want to first preserve any data left on it? –  Swizzlr Feb 1 '12 at 11:11
    
No, I already have a backup, so I don't have any need for them.. –  nuc Feb 2 '12 at 13:15

7 Answers 7

I've struggled for some days with the same problem but now it is solved. The problem was a faulty SATA cable. I've replaced it with a new one and now everything works as expected.

share|improve this answer
up vote 1 down vote accepted

Thank you all for your responses, but it seems that this is a Disk Utility/Lion bug with some 2nd/external drives.

The way it worked with me is to boot from a previous OS X version (Snow Leopard) via target-disk-mode and partition the drive from there without any problem!

share|improve this answer

It could be a physical death. This you can do nothing about. If your drive is making clicking (or any other unusual) noises, this is a serious hint for that solution.

Otherwise, try DiskWarrior. Commercial but worth it. It saved me many times from seemingly desperate situations. I owe it at least the life of my eMac, twice my main computer, and several friends'.

share|improve this answer
    
DiskWarrior is great for repairing directory problems but, given this problem cropped up during a reformat/repartition operation, it is unlikely to be a solution. –  jaberg Jan 26 '12 at 16:18

I see you have Techtool Pro (eDrive partition on your main drive). I'm not sure why it's grayed though. Techtool Pro has basic utility to check logical and physical structure of HDD, use it.

In case it's easy for you to take this HDD out and you have open PC desktop then I would recommend connect it by SATA and check it with MHDD utility.

share|improve this answer
    
I've already tried eDrive to no luck. I don't have a spare pc at the moment, but this is a nice idea.. –  nuc Jan 31 '12 at 10:33

The idea of forcing a drive (that I presumably want to trust) to format scares me. I wouldn't advocate pursuing this too far down the rabbit hole. However, I notice from the screenshot that there is no Partition Map Scheme defined for the drive. (Indicating this drive is either truly "blank" or really, really "borked".) Try clicking on the Options… button (located below the Volume Scheme: panel) and selecting the appropriate (most likely GUID) partition map.

share|improve this answer
    
I just wanted to be sure that this is not something that can be fixed.. + yes I've already tried to create a new partition, and it failed as well.. –  nuc Jan 31 '12 at 10:33
    
Just to be certain, you also defined a Partion Map type from the Options… screen? –  jaberg Jan 31 '12 at 14:44

One thing I have done in the past to (temporarily) revive a dead drive, is to stand it vertically rather than sit it flat. The read/write heads that extend in between the platters can often misalign, and gravity wants them to droop down. This is often the cause for clicking and other bad noises. If you stand the drives vertically (Try all 4 sides - you want to try to make the heada "dangle" down, rather than be stood on end etc), you may be able to get enough proper spin out of it to remove any data that me be required to be saved.

Obviously a backup is your friend in this scenario, although as you are wiping it, you are probably (hopefully) not in a position to be losing data.

One thing you can try is to check the SMART status (Apple > About this Mac > System Information - dig about) to see if it is reporting errors.

share|improve this answer

I ran into the same problem trying to set up a Hackintosh build on a new drive in my PC. The solution I used was to switch the Mac drive with my existing SSD which has Windows 7 so that the Mac one is first. This was a physical cable switch.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.