Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been trying out iBooks author, and one thing i want to be able to do is to allow text overflow from one custom text box to another. In pages this is done either by clicking the blue little symbol in the lower-right part of a text box with too much text, and link it to another, or by going to the menu format->text box->add linked text box. In iBooks Author, however, this last option is greyed out for no apparent reason, and the blue link symbol never appears. Any suggestions?

share|improve this question
    
Hmm. I have never use that before, But I got it to work on one of the text boxes by resizing it and the blue handle appeared. But can not get it to do it on others? –  markhunte Jan 23 '12 at 13:18
add comment

3 Answers

up vote 1 down vote accepted

Using the Botany sample, the text boxes seem to work as expected with the caveat that you have to intentionally click on one of the four corner handles of the text box to make the blue linking triangles appear.

I took a small video showing the controls reacting to mouse events.

From there, linking works as expected from the perspective of Pages.

flowing text boxes in iBooks Author

share|improve this answer
    
I found out that (to me) it only works if I use the already existing text boxes, by resizing them and creating new through them. This works for me, so problem solved. I had originally created a new text box with the tool visible at the tool field, and then linking won't work, for some reason. –  Mathias Bengtsson Feb 1 '12 at 16:20
add comment

I have found that it is necesary to give some special properties to the text boxes inside of layout column, for example:

  1. Select the view menu on the top bar
  2. Select Show layouts
  3. Select a textbox
  4. Open layout inspector
  5. Enable: Editable on pages using this layout

Then in format menu: Format > Text box > Show connection lines

The arrows and blue lines appear when toggling the menu item Show connection lines

When use the same layout to create a page or section, the textbox must contain tne blue arrows and connection lines to.

I found that this solution is not applicable to all the textboxes, it seems to deppend on the text style or something.

share|improve this answer
    
I cannot find the fifth step in the layout inspector. All I can choose is column width and number of columns? –  Mathias Bengtsson Jan 26 '12 at 15:59
    
This one gave me what I needed. I didn't even know where the layout editor was previously. Thanks! –  Kaji Jan 20 '13 at 16:11
add comment

This is very difficult to find. When you create the text box after Enable: Editable on pages using this layout you should use the tag body, when a text box has the tag body will show the connection lines.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.