Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I changed my iTunes account location to German (with an Austrian credit card) in order to download a certain app that wasn't available in Danish (my primary language). I was now able to get the app from the German App Store. Afterward, I set the location back to Denmark and entered the Danish credit card that I was using before.

Problem:
When I now visit the App Store (on my iPhone), it is still in German. How do I switch the iPhone App Store back to the language that is set in iTunes? iTunes has got it right, but why doesn't my iPhone see the same status?

I expected that it would be enough to just plug it into the PC and let it sync itself, but that wasn't the case. I've just synced the phone with the PC and that went without problems, but the iPhone App Store is still in German while the PC iTunes has the Danish account ("Country/Region: DNK").

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Open Settings and go to Store. From there, choose Sign Out if you're already signed in and then sign back in again. If you were not signed in, sign in now. Now check the App Store. If necessary, restart the device.

share|improve this answer
    
So simple (and yet, so well hidden) - thank you! –  Torben Gundtofte-Bruun Nov 8 '10 at 21:14
    
You're welcome. You can also sign in/out by scrolling to the bottom of the Featured view in iTunes or App Store on the iPhone. –  sentinel Nov 8 '10 at 21:20
    
This doesn't work for me. I have Japanese App Store interface from iPhone 4 and English App Store interface from iPad (a Japanese App Store, and neither of the device locals are Japan). The language just changed on me after downloading a thesaurus to iPhone, it won't change it back to English. –  user28355 Aug 31 '12 at 12:22

I had the same problem (stuck in German store/language). I called Apple support, reset the iPhone, logged into the store, switched to (in my case) my "home" store, the USA. I then restarted the phone and the settings stayed in USA/English.

To reset go to: Settings > General > Reset > Reset all Settings. This doesn't affect your data; just wipes the preferences.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.