Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When iOS 5 first came out, I added my @me address to my iPhone and iPad. People could iMessage me at my email address, and I'd see it on both devices. This wasn't always perfect, and recently I decided to forgo this, and just use my phone number on my phone and email address on the iPad.

So, I switched the caller ID on my phone to the phone number again, deleted all my text message threads that were created when I was using the email address, and started a new thread. Somebody who didn't have my email address saved in their contact asked why my text messages were coming from an email address, and another reception confirmed that when he tapped 'Contact Info' at the top of the message thread, my email address was highlight in blue, NOT my phone number - indicated that this is where the message was coming from.

Does anybody know why this is happening? Is there another setting I need to change? I'd really prefer to not have them come from my email address, because then any replies will goto both my phone and my iPad - which I don't want.

share|improve this question
add comment

6 Answers 6

Go to settings on the iPhone. Go to the 'Messages' settings. And select Receive At.

See what it says there. It should be your phone number not Apple ID or email.

If you have a Apple email listed. You can remove it by.

Clicking the 'Apple ID youremail@me.com' You will get a popup which lets sign out thus removing the mac email address. enter image description here

share|improve this answer
    
Yep, it's there, greyed out. I don't believe it's possible to remove an associated phone number from an iPhone. My email address @me.com is also listed, which it won't let me remove since it's the only email address listed. –  Gauzy Jan 22 '12 at 22:33
    
Click the 'Apple ID youremail@me.com' You will get a popup which lets sign out thus removing the mac email address. –  markhunte Jan 22 '12 at 22:42
    
My @me is the only email address listed, so the 'Remove This Email' button is greyed out. It cannot be removed. –  Gauzy Jan 22 '12 at 23:59
    
I mean click the one at the top. That looks like a label. See update to Answer –  markhunte Jan 23 '12 at 1:41
    
Gotcha - thanks. I've done that, and the email was removed. Now, though messages between me and another iOS user show up as SMS, not iMessages. We both have iMessage turned on, but this doesn't seem to matter. Both on wifi as well, so there is a decent data connection. –  Gauzy Jan 23 '12 at 22:48
show 2 more comments

Type in the person's entire phone number and do not select their name from the drop down list when it pops up. This will fix it. I would also delete the old thread as to prevent yourself from using it on accident again.

share|improve this answer
add comment

Try to see if your phone number shows up on top in the "Receive At" setting. If it doesn't, there are some reported cases where people have solved the problem by turning off iMessage, resetting Network Settings and then turn iMessage back on. I've had some difficulties in verifying my number one time I swapped the SIM card for another one and then back to the original SIM, and I managed to get it active again by doing this reset. Please note that you'll lose all the memorized Wi-Fi networks and their passwords by doing this.

Meanwhile you should also disable "Send As SMS". In case an iMessage doesn't get delivered, the only difference is that it will ask if you want to send it as a SMS.

I wouldn't worry to delete your previous message threads. Your iPhone will handle that. They will surely appear as a different thread on your friends' iOS device, because they come from a different sender.

Please let me know if this solves your problem.

share|improve this answer
    
It does show up on top - my @me.com email address is below it. I'll give the resetting network settings bit a shot. Haven't heard of disabling send as SMS - I'll try that. The reason I removed my previous message threads was really more of a test scenario, so I could see each new message as they came in to see where it was coming from/going to. –  Gauzy Jan 22 '12 at 22:34
add comment

When i deleted my apple id from the imessenger bit it added my telephone number into the box instead but it also turned imessenger off, so you will need to turn it back on in your settings.Hope this helps.

share|improve this answer
add comment

my phone number was showing greyed out with "error". When i turned iMessages off and then back on it showed back up. Looks like it fixed it.

share|improve this answer
add comment

Just had this problem. Turned iMessages off and on again. It happened after I put a different SIM-card in my phone. Works fine now. :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.