Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Yesterday I could play music and actually hear something, but as of today, my MacBook Pro speakers aren't producing any sound at all.

Here is what I tried:

  • rebooting (a cold reboot too) several times
  • internal/external speakers
  • PRAM reset
  • Reinstall iTunes
  • Using headphones

There is no red light in the headphone jack.

The only thing I did was updating my iTunes to the new 10.5.3 version. But I doubt this is the cause because other programs aren't reproducing any sound too. So, no sound at all on my MacBook Pro (mid 2011). Any idea or hits to get the sound back?

EDIT
And to make it even more weird, the mail-app is making sound when sending and receiving mails. But iTunes, QuickTime, VLC, Safari,... These apps aren't making any sound at all!

share|improve this question
    
Can you listen to music using headphones? Is the red LED in the headphone jack on when there is nothing inside? –  gentmatt Jan 21 '12 at 15:33
    
To both questions, nope... –  Michiel Jan 21 '12 at 15:36
    
You've double-checked to make sure that audio wasn't muted using the keyboard? –  jaberg Jan 21 '12 at 20:20
    
Yes, I even tripple checked it! –  Michiel Jan 21 '12 at 21:22
    
The audio output is set to "Internal Speakers"? –  timothymh Jan 23 '12 at 1:44
show 1 more comment

1 Answer 1

up vote 2 down vote accepted

In the first instance, please repair disk permissions. If that makes no difference please try starting your machine in Safe Mode before restarting (back to normal mode) and seeing if that made any difference.

If neither of these work I would reinstall the OS over the top at this stage.

As to the cause? I think the Quicktime system plugin has incorrect permissions, is damaged or just plain isn't where it should be. Let us know how you get on!

share|improve this answer
    
I'll as soon as I get home! Thanks for the help! –  Michiel Jan 23 '12 at 10:42
    
Hurray hurray hurray! I did safe restart, rebuilding and plugging in the headphone jack. All of them a few times and finally, the sound was back! Thanks a lot! –  Michiel Jan 23 '12 at 22:32
    
You're welcome, glad to hear it worked. –  Robin Jan 23 '12 at 22:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.