Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently upgraded my Mac Pro with 24Gb of ram, quite the nice feeling.

When I booted up the system again, I got this message :

Memory utility

Quite nice I thought, seems the memory is working as it should. And apparently, it is.

But now, every time I reboot my computer, Memory Slot Utility feels the need to tell me this again. Ive been trying to find a setting or app for this Memory Slot Utility, but with no luck.

Does anyone know how to silence this on start alert forever ?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

You can turn it off by logging in once as the root user. Root's disabled by default, but here's how to enable it and log in as root:

Steps taken from here: http://www.dreness.com/blog/?p=231


  1. In Finder, choose Go –> Go to Folder... (or shift command g), and enter /System/Library/CoreServices

  2. In the CoreServices folder, open Directory Utility.

  3. From the Edit menu, choose "Enable Root User", and supply a password.

  4. Open System Preferences –> Users & Groups prefpane, and under Login Options, turn off Automatic Login, and set the login window display to Name and Password.

  5. Reboot. Log in as root from the login window. Perform one final heroic click of Memory Slot Utility’s OK button, going for maximum style points.

  6. Log out, log back in as yourself, put settings back the way you like them. I suggest using Directory Utility to disable the root account.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.