Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an early 2010 27" iMac that is the family computer. It has 5 user accounts on it. (Not sure if this is relevant or not).

Often times I'll come home and the login screen won't appear. Usually I can ssh in from my MBP and kill that process and everything works.

This time, however, I see that there's a few hundred loginwindow processes running, and I can't kill them. Doing a ps ax | grep loginwindow | wc -l told me there was 829 of them!

It started with a frozen screensaver. I killed the ScreenSaverEngine process and it brought me to a stuck login screen.

I'm guessing there is a severe software conflict on the machine, but I am not sure how to diagnose this. It is certainly frustrating to have to power off the machine.

Any ideas on what I should do to fix this issue? How would I begin to figure out the root cause?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted
+50

Alright these are the olden goldies for fixing stuff like that:

1) Repair Permissions:

This is often a bit of a sacrificial chicken but in this case it could very well be that something has caused the permissions on the login database or an associated file to end up corrupted.

2) Verify the disk: It's unlikely to be a disk problem but whilst you're in there you might as well clear that off.

If they don't do the trick once you're logged back in go to Console in Utilities and post the log files up here, there might be some useful information in them.

share|improve this answer
    
I did try repairing permissions, but it's worth another shot. –  Ben Scheirman Mar 5 '12 at 21:47
    
Ok there were a couple of invalid permissions. I've run the Repair Permissions and Verify Disk. –  Ben Scheirman Mar 5 '12 at 22:27
    
Now I suppose it's just wait & see if it happens again... :/ –  Ben Scheirman Mar 5 '12 at 22:29
    
I suspect that the culprit was the Parental controls, as I saw this in top when the issue was happening, and after repairing permissions I removed parental controls from all user accounts. Problem hasn't happened all week. –  Ben Scheirman Mar 10 '12 at 16:51
    
Glad to hear it was solved! –  Nicholas Smith Mar 11 '12 at 10:17
add comment

I don't know if this is your problem but, there's a known issue I've seen on my iMac with multiple accounts that are set to automatically log out. The last screen image will appear frozen. A mouse swipe will show squares of a login screen underneath that appears to be rewritten with the mouse swipes. What I do is from the keyboard, start typeing the characters of the user you wish to log in and the relevant part of the login screen appears. From there just login as usual.

May be similar to Scrape away screen layer.

share|improve this answer
    
That doesn't really match my experience, but thanks for posting :) –  Ben Scheirman Mar 7 '12 at 15:00
add comment

What version of the OS? Any recent software or hardware changes?

Can you replicate the problem if you perform a safe boot?

I'd probably next try emptying all system, local, and user caches with something like Lion Cache Cleaner - I'd avoid AppleJack or Onyx as they often install components to the system that may further complicate troubleshooting. I'd probably also try re-applying the Combo Updater for whatever version of the OS you're using.

And, as always, verify that your backups are running and usable..

share|improve this answer
    
This is with 10.7.3 –  Ben Scheirman Mar 10 '12 at 16:35
    
The issue with a safe boot is that the issue occurs pretty randomly. A reboot usually fixes it. –  Ben Scheirman Mar 10 '12 at 16:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.