Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Here's the setting: I am syncing my entire books library on my MacBook with my iPad. On my Mac, there are 122 books (both .epub and.pdf). I also use iTunes U on my MacBook, and some of the courses I download have .pdf slides in addition to videos. However, I am not syncing iTunes U courses on my MacBook with my iPad.

And here's the issue: somehow, all the course slides from iTunes U appear in my books library on the iPad. That is, my books library on the iPad now contains 129 books, and the number is growing with every slide set that I download. So these slides appear in iBooks, but not in my books library on my MacBook. In short, I say sync all books, and it laughs into my face by syncing to different numbers.

How do I turn this feature off? Is it some setting that I've missed, a weird feature, or an annoying bug?

share|improve this question
    
Have you tried resetting the iTunes U data on the iPad by letting it sync one small portion of iTunes U and sync to completion. Then disable iTunes U syncing. It should then offer to let you keep or delete all the items. As a long shot, be sure manually manage music isn't also set and look to clean out any "manually" added items. Even if you didn't add them, it doesn't mean the device's database hasn't corrupted and marked some items as manually synced and thereby think it shouldn't touch them. –  bmike Jan 19 '12 at 15:41
    
Thanks for the suggestion, but nope, that did not work. –  ernes7a Jan 20 '12 at 10:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.